Apache ActiveMQ Deserialization of Untrusted Data vulnerability
CVE-2022-41678GHSA-53v4-42fg-g287
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.activemq:apache-activemq 5.17.4, 5.16.6), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.apache.activemq:apache-activemq
- Affected
- < 5.16.6>= 5.17.0, < 5.17.4
- Fixed in
- 5.16.6, 5.17.4
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-53v4-42fg-g287 lists affected ranges: Maven org.apache.activemq:apache-activemq >=0 =5.17.0 <5.17.4
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.8 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2022-41678: 85.81% estimated exploitation activity in the next 30 days; percentile 99.73 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Once an user is authenticated on Jolokia, he can potentially trigger arbitrary code execution. In details, in ActiveMQ configurations, jetty allows org.jolokia.http.AgentServlet to handler request to /api/jolokia org.jolokia.http.HttpRequestHandler#handlePostRequest is able to create JmxRequest through JSONObject. And calls to org.jolokia.http.HttpRequestHandler#executeRequest. Into deeper calling stacks, org.jolokia.handler.ExecHandler#doHandleRequest is able to invoke through refection. And then, RCE is able to be achieved via jdk.management.jfr.FlightRecorderMXBeanImpl which exists on Java version above 11. 1 Call newRecording. 2 Call setConfiguration. And a webshell data hides in it. 3 Call startRecording. 4 Call copyTo method. The webshell will be written to a .jsp file. The mitigation is to restrict (by default) the actions authorized on Jolokia, or disable Jolokia. A more restrictive Jolokia configuration has been defined in default ActiveMQ distribution. We encourage users to…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-53v4-42fg-g287
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-41678 Advisory: Apache ActiveMQ Deserialization of Untrusted Data vulnerability IDs: CVE-2022-41678, GHSA-53v4-42fg-g287 Record: https://patchnext.com/advisories/cve-2022-41678 (revision 1, source checked 26 Oct 2026, 16:40 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.apache.activemq:apache-activemq 5.17.4, 5.16.6. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.apache.activemq:apache-activemq: affected < 5.16.6; >= 5.17.0, < 5.17.4; fixed in 5.16.6, 5.17.4 ## Suggested inspection (read-only) - Maven org.apache.activemq:apache-activemq: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.apache.activemq:apache-activemq. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-53v4-42fg-g287 (GitHub-reviewed advisory GHSA-53v4-42fg-g287 lists affected ranges: Maven org.apache.activemq:apache-activemq >=0 =5.17.0 <5.17.4) Commands are suggestions: review each one before running it.
Loading voting…