ghost vulnerable to unauthorized newsletter modification via improper access controls
CVE-2022-41654GHSA-9gh8-wp53-ccc6
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (ghost 5.22.7, 4.48.8), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm ghost
- Affected
- >= 5.0.0, < 5.22.7>= 4.46.0, < 4.48.8
- Fixed in
- 4.48.8, 5.22.7
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-9gh8-wp53-ccc6 lists affected ranges: npm ghost >=5.0.0 =4.46.0 <4.48.8 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-9gh8-wp53-ccc6 lists affected ranges: npm ghost >=5.0.0 =4.46.0 <4.48.8
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:H/A:N
- EPSS
- CVE-2022-41654: 18.91% estimated exploitation activity in the next 30 days; percentile 97.30 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact On sites where members is enabled (this is the default) it is possible for members (unprivileged users) to make changes to newsletter settings. This gives unprivileged users the ability to view and change settings they were not intended to have access to. They are not able to escalate their privileges permanently or get access to further information. This issue was caused by a gap in our API validation for nested objects. Ghost(Pro) has already been patched. We can find no evidence that the issue was exploited on Ghost(Pro) prior to the patch being added. Self-hosters are impacted if running Ghost a version between v4.46.0 and v4.48.7 or any version of v5 prior to v5.22.7. Immediate action should be taken to secure your site - see patches & workarounds below. Patches - v4.48.8 / v5.22.7 are patched for all known exploits. - v4.48.9 / v5.24.1 contain deeper fixes to the API to close the potential for this vulnerability to appear elsewhere or regress Workarounds The known…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-9gh8-wp53-ccc6
- Revision 1 · created ·
Published from osv record GHSA-9gh8-wp53-ccc6
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-41654 Advisory: ghost vulnerable to unauthorized newsletter modification via improper access controls IDs: CVE-2022-41654, GHSA-9gh8-wp53-ccc6 Record: https://patchnext.com/advisories/cve-2022-41654 (revision 2, source checked 26 Oct 2026, 12:17 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: ghost 5.22.7, 4.48.8. A vendor fix does not mean a deployment is fixed. ## Affected components - npm ghost: affected >= 5.0.0, < 5.22.7; >= 4.46.0, < 4.48.8; fixed in 4.48.8, 5.22.7 ## Suggested inspection (read-only) - `npm ls ghost --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on ghost. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-9gh8-wp53-ccc6 (OSV record GHSA-9gh8-wp53-ccc6 lists affected ranges: npm ghost >=5.0.0 =4.46.0 <4.48.8 (fixed)) - Verified: https://github.com/advisories/GHSA-9gh8-wp53-ccc6 (GitHub-reviewed advisory GHSA-9gh8-wp53-ccc6 lists affected ranges: npm ghost >=5.0.0 =4.46.0 <4.48.8) Commands are suggestions: review each one before running it.
Loading voting…