Skip to content

← Actionable
Critical, CVSS 9.8amended

Nadesiko3 OS Command Injection vulnerability

CVE-2022-41642GHSA-m8r5-7wf4-63mw

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (nadesiko3 3.3.69), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2022-41642: 2.15% estimated exploitation activity in the next 30 days; percentile 82.13 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

OS command injection vulnerability in Nadesiko3 (PC Version) v3.3.68 and earlier allows a remote attacker to execute an arbitrary OS command when processing compression and decompression on the product. Release notes for versions 3.3.62 and 3.3.69 both link to patches for this particular issue. The JPCERT/CC advisory lists versions 3.3.68 and prior as vulnerable, and the most recent patch for this issue is tagged with version 3.3.69.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-m8r5-7wf4-63mw

  2. Revision 1 · created ·

    Published from osv record GHSA-m8r5-7wf4-63mw

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-41642

Advisory: Nadesiko3 OS Command Injection vulnerability
IDs: CVE-2022-41642, GHSA-m8r5-7wf4-63mw
Record: https://patchnext.com/advisories/cve-2022-41642 (revision 2, source checked 26 Oct 2026, 12:17 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: nadesiko3 3.3.69. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm nadesiko3: affected <= 3.3.68; fixed in 3.3.69

## Suggested inspection (read-only)
- `npm ls nadesiko3 --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on nadesiko3.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-m8r5-7wf4-63mw (OSV record GHSA-m8r5-7wf4-63mw lists affected ranges: npm nadesiko3 >=0 <3.3.69 (fixed))
- Verified: https://github.com/advisories/GHSA-m8r5-7wf4-63mw (GitHub-reviewed advisory GHSA-m8r5-7wf4-63mw lists affected ranges: npm nadesiko3 >=0 <=3.3.68)

Commands are suggestions: review each one before running it.

Loading voting…