Skip to content

← Actionable
Medium, CVSS 6.5amended

ToolJet is vulnerable to Denial of Service (DoS)

CVE-2022-4111GHSA-hgp8-w8fj-r4cm

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (tooljet 1.27.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm tooljet

    Affected
    < 1.27.0
    Fixed in
    1.27.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2022-4111: 0.82% estimated exploitation activity in the next 30 days; percentile 57.30 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

ToolJet/ToolJet placed no limit on the file size for user avatars. This could cause a denial of service if too many users upload large files. This is fixed in commit 01cd3f0464747973ec329e9fb1ea12743d3235cc in version 1.27.0. tooljet is no longer listed on npmjs.com but was listed on npmjs.com in the past. This advisory is maintained for historical completeness.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-hgp8-w8fj-r4cm

  2. Revision 1 · created ·

    Published from osv record GHSA-hgp8-w8fj-r4cm

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-4111

Advisory: ToolJet is vulnerable to Denial of Service (DoS)
IDs: CVE-2022-4111, GHSA-hgp8-w8fj-r4cm
Record: https://patchnext.com/advisories/cve-2022-4111 (revision 2, source checked 26 Oct 2026, 12:22 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: tooljet 1.27.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm tooljet: affected < 1.27.0; fixed in 1.27.0

## Suggested inspection (read-only)
- `npm ls tooljet --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on tooljet.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-hgp8-w8fj-r4cm (OSV record GHSA-hgp8-w8fj-r4cm lists affected ranges: npm tooljet >=0 <1.27.0 (fixed))
- Verified: https://github.com/advisories/GHSA-hgp8-w8fj-r4cm (GitHub-reviewed advisory GHSA-hgp8-w8fj-r4cm lists affected ranges: npm tooljet >=0 <1.27.0)

Commands are suggestions: review each one before running it.

Loading voting…