.NET Remote Code Execution Vulnerability
CVE-2022-41089GHSA-2c7v-qcjp-4mg2
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (microsoft.windowsdesktop.app.runtime.win-x86 7.0.1, 6.0.12, 3.1.32; microsoft.windowsdesktop.app.runtime.win-arm64 7.0.1, 6.0.12; microsoft.windowsdesktop.app.runtime.win-x64 7.0.1, 6.0.12, 3.1.32), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
NuGet microsoft.windowsdesktop.app.runtime.win-x86
- Affected
- >= 3.1.0, <= 3.1.31>= 6.0.0, <= 6.0.11>= 7.0.0, <= 7.0.0
- Fixed in
- 7.0.1, 3.1.32, 6.0.12
NuGet microsoft.windowsdesktop.app.runtime.win-arm64
- Affected
- >= 6.0.0, <= 6.0.11>= 7.0.0, <= 7.0.0
- Fixed in
- 7.0.1, 6.0.12
NuGet microsoft.windowsdesktop.app.runtime.win-x64
- Affected
- >= 3.1.0, <= 3.1.31>= 6.0.0, <= 6.0.11>= 7.0.0, <= 7.0.0
- Fixed in
- 7.0.1, 3.1.32, 6.0.12
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-2c7v-qcjp-4mg2 lists affected ranges: NuGet microsoft.windowsdesktop.app.runtime.win-x64 >=3.1.0 =6.0.0 =7.0.0 =3.1.0 =6.0.0 =7.0.0 =6.0.0 =7.0.0 <=7.0.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
- EPSS
- CVE-2022-41089: 1.19% estimated exploitation activity in the next 30 days; percentile 68.08 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Microsoft Security Advisory CVE-2022-41089: .NET Remote Code Execution Vulnerability <a name="executive-summary"</aExecutive summary Microsoft is releasing this security advisory to provide information about a vulnerability in .NET Core 3.1, .NET 6.0., and .NET 7.0. This advisory also provides guidance on what developers can do to update their applications to remove this vulnerability. A remote code execution vulnerability exists in .NET Core 3.1, .NET 6.0, and .NET 7.0, where a malicious actor could cause a user to run arbitrary code as a result of parsing maliciously crafted xps files. Announcement Announcement for this issue can be found at https://github.com/dotnet/announcements/issues/242 <a name="mitigation-factors"</aMitigation factors Microsoft has not identified any mitigating factors for this vulnerability. <a name="affected-software"</aAffected software Any .NET 7.0 WinForms or WPF application running on .NET 7.0.0 or earlier. Any .NET 6.0 WinForms or WPF application…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-2c7v-qcjp-4mg2
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-41089 Advisory: .NET Remote Code Execution Vulnerability IDs: CVE-2022-41089, GHSA-2c7v-qcjp-4mg2 Record: https://patchnext.com/advisories/cve-2022-41089 (revision 1, source checked 26 Oct 2026, 17:00 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: microsoft.windowsdesktop.app.runtime.win-x86 7.0.1, 6.0.12, 3.1.32; microsoft.windowsdesktop.app.runtime.win-arm64 7.0.1, 6.0.12; microsoft.windowsdesktop.app.runtime.win-x64 7.0.1, 6.0.12, 3.1.32. A vendor fix does not mean a deployment is fixed. ## Affected components - NuGet microsoft.windowsdesktop.app.runtime.win-x86: affected >= 3.1.0, <= 3.1.31; >= 6.0.0, <= 6.0.11; >= 7.0.0, <= 7.0.0; fixed in 7.0.1, 3.1.32, 6.0.12 - NuGet microsoft.windowsdesktop.app.runtime.win-arm64: affected >= 6.0.0, <= 6.0.11; >= 7.0.0, <= 7.0.0; fixed in 7.0.1, 6.0.12 - NuGet microsoft.windowsdesktop.app.runtime.win-x64: affected >= 3.1.0, <= 3.1.31; >= 6.0.0, <= 6.0.11; >= 7.0.0, <= 7.0.0; fixed in 7.0.1, 3.1.32, 6.0.12 ## Suggested inspection (read-only) - NuGet microsoft.windowsdesktop.app.runtime.win-x86: check the installed version with your package manager. - NuGet microsoft.windowsdesktop.app.runtime.win-arm64: check the installed version with your package manager. - NuGet microsoft.windowsdesktop.app.runtime.win-x64: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on microsoft.windowsdesktop.app.runtime.win-x86, microsoft.windowsdesktop.app.runtime.win-arm64, microsoft.windowsdesktop.app.runtime.win-x64. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-2c7v-qcjp-4mg2 (GitHub-reviewed advisory GHSA-2c7v-qcjp-4mg2 lists affected ranges: NuGet microsoft.windowsdesktop.app.runtime.win-x64 >=3.1.0 =6.0.0 =7.0.0 =3.1.0 =6.0.0 =7.0.0 =6.0.0 =7.0.0 <=7.0.0) Commands are suggestions: review each one before running it.
Loading voting…