Skip to content

← Actionable
Critical, CVSS 9.8

SQL injection in Dolibarr

CVE-2022-4093GHSA-gjg7-qfvp-9hm4

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (dolibarr/dolibarr 16.0.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2022-4093: 4.30% estimated exploitation activity in the next 30 days; percentile 91.15 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

SQL injection attacks can result in unauthorized access to sensitive data, such as passwords, credit card details, or personal user information. Many high-profile data breaches in recent years have been the result of SQL injection attacks, leading to reputational damage and regulatory fines. In some cases, an attacker can obtain a persistent backdoor into an organization's systems, leading to a long-term compromise that can go unnoticed for an extended period. This affect 16.0.1 and 16.0.2 only. 16.0.0 or lower, and 16.0.3 or higher are not affected

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-gjg7-qfvp-9hm4

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-4093

Advisory: SQL injection in Dolibarr
IDs: CVE-2022-4093, GHSA-gjg7-qfvp-9hm4
Record: https://patchnext.com/advisories/cve-2022-4093 (revision 1, source checked 26 Oct 2026, 14:05 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: dolibarr/dolibarr 16.0.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist dolibarr/dolibarr: affected >= 16.0.1, < 16.0.3; fixed in 16.0.3

## Suggested inspection (read-only)
- Packagist dolibarr/dolibarr: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on dolibarr/dolibarr.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-gjg7-qfvp-9hm4 (GitHub-reviewed advisory GHSA-gjg7-qfvp-9hm4 lists affected ranges: Packagist dolibarr/dolibarr >=16.0.1 <16.0.3)

Commands are suggestions: review each one before running it.

Loading voting…