pypa/setuptools vulnerable to Regular Expression Denial of Service (ReDoS)
CVE-2022-40897GHSA-r9hx-vwmv-q579
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (setuptools 65.5.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI setuptools
- Affected
- < 65.5.1
- Fixed in
- 65.5.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-r9hx-vwmv-q579 lists affected ranges: PyPI setuptools >=0 <65.5.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-r9hx-vwmv-q579 lists affected ranges: PyPI setuptools >=0 <65.5.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:L/SI:L/SA:N · score source
- EPSS
- CVE-2022-40897: 2.63% estimated exploitation activity in the next 30 days; percentile 85.56 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Python Packaging Authority (PyPA)'s setuptools is a library designed to facilitate packaging Python projects. Setuptools version 65.5.0 and earlier could allow remote attackers to cause a denial of service by fetching malicious HTML from a PyPI package or custom PackageIndex page due to a vulnerable Regular Expression in packageindex. This has been patched in version 65.5.1.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-r9hx-vwmv-q579
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-r9hx-vwmv-q579
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-40897 Advisory: pypa/setuptools vulnerable to Regular Expression Denial of Service (ReDoS) IDs: CVE-2022-40897, GHSA-r9hx-vwmv-q579 Record: https://patchnext.com/advisories/cve-2022-40897 (revision 3, source checked 26 Oct 2026, 13:35 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: setuptools 65.5.1. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI setuptools: affected < 65.5.1; fixed in 65.5.1 ## Suggested inspection (read-only) - `python -m pip show setuptools`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on setuptools. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-r9hx-vwmv-q579 (OSV record GHSA-r9hx-vwmv-q579 lists affected ranges: PyPI setuptools >=0 <65.5.1 (fixed)) - Verified: https://github.com/advisories/GHSA-r9hx-vwmv-q579 (GitHub-reviewed advisory GHSA-r9hx-vwmv-q579 lists affected ranges: PyPI setuptools >=0 <65.5.1) Commands are suggestions: review each one before running it.
Loading voting…