Skip to content

← Actionable
Low, CVSS 3.7

Unsanitized input leading to code injection in Dalli

CVE-2022-4064GHSA-3xg8-cc8f-9wv2

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (dalli 3.2.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • RubyGems dalli

    Affected
    < 3.2.3
    Fixed in
    3.2.3

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
3.7 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:N
EPSS
  • CVE-2022-4064: 1.40% estimated exploitation activity in the next 30 days; percentile 72.48 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

A vulnerability was found in Dalli. Affected is the function self.metaset of the file lib/dalli/protocol/meta/requestformatter.rb of the component Meta Protocol Handler. The manipulation leads to injection. The exploit has been disclosed to the public and may be used. The name of the patch is 48d594dae55934476fec61789e7a7c3700e0f50d. It is recommended to apply a patch to fix this issue.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-3xg8-cc8f-9wv2

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-4064

Advisory: Unsanitized input leading to code injection in Dalli
IDs: CVE-2022-4064, GHSA-3xg8-cc8f-9wv2
Record: https://patchnext.com/advisories/cve-2022-4064 (revision 1, source checked 26 Oct 2026, 15:44 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 3.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: dalli 3.2.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- RubyGems dalli: affected < 3.2.3; fixed in 3.2.3

## Suggested inspection (read-only)
- RubyGems dalli: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on dalli.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-3xg8-cc8f-9wv2 (GitHub-reviewed advisory GHSA-3xg8-cc8f-9wv2 lists affected ranges: RubyGems dalli >=0 <3.2.3)

Commands are suggestions: review each one before running it.

Loading voting…