Skip to content

← Actionable
High, CVSS 7.1

Moodle Stored Cross-site Scripting and page denial of service

CVE-2022-40313GHSA-jqgr-gh62-jf53

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (moodle/moodle 4.0.4, 3.11.10, 3.9.17), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist moodle/moodle

    Affected
    >= 3.9, < 3.9.17>= 3.11, < 3.11.10>= 4.0, < 4.0.4
    Fixed in
    3.9.17, 3.11.10, 4.0.4

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:L
EPSS
  • CVE-2022-40313: 0.72% estimated exploitation activity in the next 30 days; percentile 53.81 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Recursive rendering of Mustache template helpers containing user input could, in some cases, result in an Cross-site Scripting risk or a page failing to load.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-jqgr-gh62-jf53

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-40313

Advisory: Moodle Stored Cross-site Scripting and page denial of service
IDs: CVE-2022-40313, GHSA-jqgr-gh62-jf53
Record: https://patchnext.com/advisories/cve-2022-40313 (revision 1, source checked 26 Oct 2026, 14:19 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: moodle/moodle 4.0.4, 3.11.10, 3.9.17. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist moodle/moodle: affected >= 3.9, < 3.9.17; >= 3.11, < 3.11.10; >= 4.0, < 4.0.4; fixed in 3.9.17, 3.11.10, 4.0.4

## Suggested inspection (read-only)
- Packagist moodle/moodle: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on moodle/moodle.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-jqgr-gh62-jf53 (GitHub-reviewed advisory GHSA-jqgr-gh62-jf53 lists affected ranges: Packagist moodle/moodle >=3.9 =3.11 =4.0 <4.0.4)

Commands are suggestions: review each one before running it.

Loading voting…