Skip to content

← Actionable
Medium, CVSS 5.4

Centreon contains cross-site scripting vulnerability via esc_name parameter

CVE-2022-40044GHSA-rv5q-72p2-2q24

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (centreon/centreon 22.04.1, 21.10.8, 21.04.16), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist centreon/centreon

    Affected
    < 21.04.16>= 21.10.0, < 21.10.8>= 22.0.0, < 22.04.1
    Fixed in
    21.04.16, 22.04.1, 21.10.8

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.4 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
EPSS
  • CVE-2022-40044: 0.77% estimated exploitation activity in the next 30 days; percentile 55.68 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Centreon v20.10.18 was discovered to contain a cross-site scripting (XSS) vulnerability via the escname (Escalation Name) parameter at Configuration/Notifications/Escalations. This vulnerability allows attackers to execute arbitrary web scripts or HTML via injecting a crafted payload. Versions 21.04.16, 21.10.8, and 22.04.2 contain patches.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-rv5q-72p2-2q24

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-40044

Advisory: Centreon contains cross-site scripting vulnerability via esc_name parameter
IDs: CVE-2022-40044, GHSA-rv5q-72p2-2q24
Record: https://patchnext.com/advisories/cve-2022-40044 (revision 1, source checked 26 Oct 2026, 14:00 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: centreon/centreon 22.04.1, 21.10.8, 21.04.16. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist centreon/centreon: affected < 21.04.16; >= 21.10.0, < 21.10.8; >= 22.0.0, < 22.04.1; fixed in 21.04.16, 22.04.1, 21.10.8

## Suggested inspection (read-only)
- Packagist centreon/centreon: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on centreon/centreon.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-rv5q-72p2-2q24 (GitHub-reviewed advisory GHSA-rv5q-72p2-2q24 lists affected ranges: Packagist centreon/centreon >=0 =21.10.0 =22.0.0 <22.04.1)

Commands are suggestions: review each one before running it.

Loading voting…