Skip to content

← Actionable
High, CVSS 8.7

Denial of service by double-checked locking in openssl-src

CVE-2022-3996GHSA-vr8j-hgmm-jh9r

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (openssl-src 300.0.12), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • crates.io openssl-src

    Affected
    >= 300.0.0, < 300.0.12
    Fixed in
    300.0.12

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2022-3996: 1.31% estimated exploitation activity in the next 30 days; percentile 70.70 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

If an X.509 certificate contains a malformed policy constraint and policy processing is enabled, then a write lock will be taken twice recursively. On some operating systems (most widely: Windows) this results in a denial of service when the affected process hangs. Policy processing being enabled on a publicly facing server is not considered to be a common setup. Policy processing is enabled by passing the -policy' argument to the command line utilities or by calling either X509VERIFYPARAMadd0policy()' or X509VERIFYPARAMset1policies()' functions.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-vr8j-hgmm-jh9r

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-3996

Advisory: Denial of service by double-checked locking in openssl-src
IDs: CVE-2022-3996, GHSA-vr8j-hgmm-jh9r
Record: https://patchnext.com/advisories/cve-2022-3996 (revision 1, source checked 26 Oct 2026, 15:38 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: openssl-src 300.0.12. A vendor fix does not mean a deployment is fixed.

## Affected components
- crates.io openssl-src: affected >= 300.0.0, < 300.0.12; fixed in 300.0.12

## Suggested inspection (read-only)
- crates.io openssl-src: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on openssl-src.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-vr8j-hgmm-jh9r (GitHub-reviewed advisory GHSA-vr8j-hgmm-jh9r lists affected ranges: crates.io openssl-src >=300.0.0 <300.0.12)

Commands are suggestions: review each one before running it.

Loading voting…