Matrix-appservice-irc vulnerable to sql injection via roomIds argument
CVE-2022-3971GHSA-ffwf-47x2-jpr8
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (matrix-appservice-irc 0.36.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- < 0.36.0
- Fixed in
- 0.36.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-ffwf-47x2-jpr8 lists affected ranges: npm matrix-appservice-irc >=0 <0.36.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-ffwf-47x2-jpr8 lists affected ranges: npm matrix-appservice-irc >=0 <0.36.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.6 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:L
- EPSS
- CVE-2022-3971: 0.57% estimated exploitation activity in the next 30 days; percentile 47.34 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
A vulnerability was found in matrix-appservice-irc up to 0.35.1. This vulnerability affects the file src/datastore/postgres/PgDataStore.ts. The manipulation of the argument roomIds leads to sql injection. Upgrading to version 0.36.0 is able to address this issue. The name of the patch is 179313a37f06b298150edba3e2b0e5a73c1415e7. It is recommended to upgrade the affected component.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-ffwf-47x2-jpr8
- Revision 1 · created ·
Published from osv record GHSA-ffwf-47x2-jpr8
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-3971 Advisory: Matrix-appservice-irc vulnerable to sql injection via roomIds argument IDs: CVE-2022-3971, GHSA-ffwf-47x2-jpr8 Record: https://patchnext.com/advisories/cve-2022-3971 (revision 2, source checked 26 Oct 2026, 12:16 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.6) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: matrix-appservice-irc 0.36.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm matrix-appservice-irc: affected < 0.36.0; fixed in 0.36.0 ## Suggested inspection (read-only) - `npm ls matrix-appservice-irc --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on matrix-appservice-irc. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-ffwf-47x2-jpr8 (OSV record GHSA-ffwf-47x2-jpr8 lists affected ranges: npm matrix-appservice-irc >=0 <0.36.0 (fixed)) - Verified: https://github.com/advisories/GHSA-ffwf-47x2-jpr8 (GitHub-reviewed advisory GHSA-ffwf-47x2-jpr8 lists affected ranges: npm matrix-appservice-irc >=0 <0.36.0) Commands are suggestions: review each one before running it.
Loading voting…