Skip to content

← Actionable
Critical, CVSS 9.1

XWiki OIDC Authenticator vulnerable to bypassing OpenID login by providing a custom provider

CVE-2022-39387GHSA-m7gv-v8xx-v47w

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.xwiki.contrib.oidc:oidc-authenticator 1.29.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H
EPSS
  • CVE-2022-39387: 1.19% estimated exploitation activity in the next 30 days; percentile 68.02 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Even if a wiki has an OpenID provider configured through its xwiki.properties, it is possible to provide a third party provider by providing its details through request parameters. One can then bypass the XWiki authentication altogether by specifying its own provider through the oidc.endpoint. request parameters (or by using an XWiki-based OpenID provider with oidc.xwikiprovider. With the same approach, one could also provide a specific group mapping through oidc.groups.mapping that would make his user automatically part of the XWikiAdminGroup Patches Patched in version 1.29.1. Workarounds There is no workaround, an upgrade of the authenticator is required. References https://jira.xwiki.org/browse/OIDC-118 For more information If you have any questions or comments about this advisory: Open an issue in Jira XWiki Email us at our security mailing list

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-m7gv-v8xx-v47w

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-39387

Advisory: XWiki OIDC Authenticator vulnerable to bypassing OpenID login by providing a custom provider
IDs: CVE-2022-39387, GHSA-m7gv-v8xx-v47w
Record: https://patchnext.com/advisories/cve-2022-39387 (revision 1, source checked 26 Oct 2026, 16:02 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.xwiki.contrib.oidc:oidc-authenticator 1.29.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.xwiki.contrib.oidc:oidc-authenticator: affected < 1.29.1; fixed in 1.29.1

## Suggested inspection (read-only)
- Maven org.xwiki.contrib.oidc:oidc-authenticator: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.xwiki.contrib.oidc:oidc-authenticator.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-m7gv-v8xx-v47w (GitHub-reviewed advisory GHSA-m7gv-v8xx-v47w lists affected ranges: Maven org.xwiki.contrib.oidc:oidc-authenticator >=0 <1.29.1)

Commands are suggestions: review each one before running it.

Loading voting…