fastify/websocket vulnerable to uncaught exception via crash on malformed packet
CVE-2022-39386GHSA-4pcg-wr6c-h9cq
What to do
Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm fastify-websocket
- Affected
- <= 4.3.0
- Fixed in
- no fixed version recorded
npm @fastify/websocket
- Affected
- >= 6.0.0, < 7.1.1>= 5.0.0, < 5.0.1
- Fixed in
- 7.1.1, 5.0.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-4pcg-wr6c-h9cq lists affected ranges: npm @fastify/websocket >=5.0.0 =6.0.0 =0 <=4.3.0
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-4pcg-wr6c-h9cq lists affected ranges: npm @fastify/websocket >=6.0.0 =5.0.0 =0 <=4.3.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2022-39386: 0.80% estimated exploitation activity in the next 30 days; percentile 56.46 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Any application using @fastify/websocket could crash if a specific, malformed packet is sent. All versions of fastify-websocket are also impacted. That module is deprecated, so it will not be patched. Patches This has been patched in v7.1.1 (fastify v4) and v5.0.1 (fastify v3). Workarounds No known workaround is available. However, it should be possible to attach the error handler manually. The recommended path is upgrading to the patched versions. Credits marcolanaro for finding and patching this vulnerability For more information If you have any questions or comments about this advisory: Open an issue in @fastify/websocket Email us at hello@matteocollina.com
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-4pcg-wr6c-h9cq
- Revision 1 · created ·
Published from osv record GHSA-4pcg-wr6c-h9cq
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-39386 Advisory: fastify/websocket vulnerable to uncaught exception via crash on malformed packet IDs: CVE-2022-39386, GHSA-4pcg-wr6c-h9cq Record: https://patchnext.com/advisories/cve-2022-39386 (revision 2, source checked 26 Oct 2026, 12:21 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Partial vendor fix; fixed versions by package: @fastify/websocket 7.1.1, 5.0.1. A vendor fix does not mean a deployment is fixed. ## Affected components - npm fastify-websocket: affected <= 4.3.0 - npm @fastify/websocket: affected >= 6.0.0, < 7.1.1; >= 5.0.0, < 5.0.1; fixed in 7.1.1, 5.0.1 ## Suggested inspection (read-only) - `npm ls fastify-websocket --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. - `npm ls @fastify/websocket --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on fastify-websocket, @fastify/websocket. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-4pcg-wr6c-h9cq (OSV record GHSA-4pcg-wr6c-h9cq lists affected ranges: npm @fastify/websocket >=5.0.0 =6.0.0 =0 <=4.3.0) - Verified: https://github.com/advisories/GHSA-4pcg-wr6c-h9cq (GitHub-reviewed advisory GHSA-4pcg-wr6c-h9cq lists affected ranges: npm @fastify/websocket >=6.0.0 =5.0.0 =0 <=4.3.0) Commands are suggestions: review each one before running it.
Loading voting…