Skip to content

← Actionable
Medium, CVSS 5.9

Incorrect is_static parameter for custom stateful precompiles in SputnikVM (evm)

CVE-2022-39354GHSA-hhc4-47rh-cr34

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (evm 0.36.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • crates.io evm

    Affected
    <= 0.35.0
    Fixed in
    0.36.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.9 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:N
EPSS
  • CVE-2022-39354: 0.68% estimated exploitation activity in the next 30 days; percentile 52.54 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact A custom stateful precompile can use the isstatic parameter to determine if the call is executed in a static context (via STATICCALL), and thus decide if stateful operations should be done. Previously, the passed isstatic parameter was incorrect -- it was only set to true if the call comes from a direct STATICCALL opcode. However, once a static call context is entered, it should stay static. The issue only impacts custom precompiles that actually uses isstatic. The maintainers estimate the usage is low. However, for those affected, it can lead to possible incorrect state transitions. Patches PR: https://github.com/rust-blockchain/evm/pull/133 Released in v0.36.0. Older patch versions can be released on request if anyone needs them. Simply contact @sorpaas by email to request it. For more information If you have any questions or comments about this advisory: Open an issue in evm repo Email Wei at wei@that.world

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-hhc4-47rh-cr34

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-39354

Advisory: Incorrect is_static parameter for custom stateful precompiles in SputnikVM (evm)
IDs: CVE-2022-39354, GHSA-hhc4-47rh-cr34
Record: https://patchnext.com/advisories/cve-2022-39354 (revision 1, source checked 26 Oct 2026, 15:33 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: evm 0.36.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- crates.io evm: affected <= 0.35.0; fixed in 0.36.0

## Suggested inspection (read-only)
- crates.io evm: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on evm.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-hhc4-47rh-cr34 (GitHub-reviewed advisory GHSA-hhc4-47rh-cr34 lists affected ranges: crates.io evm >=0 <=0.35.0)

Commands are suggestions: review each one before running it.

Loading voting…