Skip to content

← Actionable
Critical, CVSS 9.3

Grafana Race condition allowing privilege escalation

CVE-2022-39328GHSA-vqc4-mpj8-jxch

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/grafana/grafana 9.2.4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
9.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2022-39328: 1.08% estimated exploitation activity in the next 30 days; percentile 65.29 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Today we are releasing Grafana 9.2.4. Alongside other bug fixes, this patch release includes critical security fixes for CVE-2022-39328. Release 9.2.4, latest patch, also containing security fix: - Download Grafana 9.2.4 Appropriate patches have been applied to Grafana Cloud and as always, we closely coordinated with all cloud providers licensed to offer Grafana Pro. They have received early notification under embargo and confirmed that their offerings are secure at the time of this announcement. This is applicable to Amazon Managed Grafana and Azure Managed Grafana as a service offering. Privilege escalation Summary Internal security audit identified a race condition in the Grafana codebase, which allowed an unauthenticated user to query an arbitrary endpoint in Grafana. A race condition in the HTTP context creation could make a HTTP request being assigned the authentication/authorization middlewares of another call. Under heavy load it is possible that a call protected by a…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-vqc4-mpj8-jxch

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-39328

Advisory: Grafana Race condition allowing privilege escalation
IDs: CVE-2022-39328, GHSA-vqc4-mpj8-jxch
Record: https://patchnext.com/advisories/cve-2022-39328 (revision 1, source checked 26 Oct 2026, 15:04 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/grafana/grafana 9.2.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/grafana/grafana: affected >= 9.2.0, < 9.2.4; fixed in 9.2.4

## Suggested inspection (read-only)
- Go github.com/grafana/grafana: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/grafana/grafana.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-vqc4-mpj8-jxch (GitHub-reviewed advisory GHSA-vqc4-mpj8-jxch lists affected ranges: Go github.com/grafana/grafana >=9.2.0 <9.2.4)

Commands are suggestions: review each one before running it.

Loading voting…