Skip to content

← Actionable
Critical, CVSS 9.1amended

Field-level access-control bypass for multiselect field

CVE-2022-39322GHSA-6mhr-52mv-6v6f

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@keystone-6/core 2.3.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
EPSS
  • CVE-2022-39322: 1.46% estimated exploitation activity in the next 30 days; percentile 73.56 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact @keystone-6/core@2.2.0 || 2.3.0 users who are using the multiselect field, and provided field-level access control - are vulnerable to their field-level access control not being used. List-level access control is NOT affected. Field-level access control for fields other than multiselect are NOT affected. Example, you are vulnerable if you are using field-level access control on a multiselect like the following: Mitigation Please upgrade to @keystone-6/core = 2.3.1, where this vulnerability has been closed. Workarounds If for some reason you cannot upgrade your dependencies, you should stop using the multiselect field. Credits Thanks to Marek R for reporting and submitting the pull request to fix this problem. If you have any questions around this security advisory, please don't hesitate to contact us at security@keystonejs.com, or open an issue on GitHub. If you have a security flaw to report for any software in this repository, please see our SECURITY policy.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-6mhr-52mv-6v6f

  2. Revision 1 · created ·

    Published from osv record GHSA-6mhr-52mv-6v6f

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-39322

Advisory: Field-level access-control bypass for multiselect field
IDs: CVE-2022-39322, GHSA-6mhr-52mv-6v6f
Record: https://patchnext.com/advisories/cve-2022-39322 (revision 2, source checked 26 Oct 2026, 12:17 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @keystone-6/core 2.3.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @keystone-6/core: affected >= 2.2.0, < 2.3.1; fixed in 2.3.1

## Suggested inspection (read-only)
- `npm ls @keystone-6/core --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @keystone-6/core.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-6mhr-52mv-6v6f (OSV record GHSA-6mhr-52mv-6v6f lists affected ranges: npm @keystone-6/core >=2.2.0 <2.3.1 (fixed))
- Verified: https://github.com/advisories/GHSA-6mhr-52mv-6v6f (GitHub-reviewed advisory GHSA-6mhr-52mv-6v6f lists affected ranges: npm @keystone-6/core >=2.2.0 <2.3.1)

Commands are suggestions: review each one before running it.

Loading voting…