Skip to content

← Actionable
Medium, CVSS 4.8

Kirby CMS vulnerable to user enumeration in the code-based login and password reset forms

CVE-2022-39314GHSA-43qq-qw4x-28f8

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (getkirby/cms 3.8.1, 3.7.5.1, 3.6.6.2, 3.5.8.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist getkirby/cms

    Affected
    >= 3.5.0, < 3.5.8.2>= 3.6.0, < 3.6.6.2>= 3.7.0, < 3.7.5.1>= 3.8.0, <= 3.8.0
    Fixed in
    3.8.1, 3.7.5.1, 3.6.6.2, 3.5.8.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
4.8 · CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:N
EPSS
  • CVE-2022-39314: 0.43% estimated exploitation activity in the next 30 days; percentile 37.13 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

TL;DR This vulnerability only affects you if you are using the code or password-reset auth method with the auth.methods option. It can only be successfully exploited under server configuration conditions outside of the attacker's control. ---- Introduction User enumeration is a type of vulnerability that allows attackers to confirm which users are registered in a Kirby installation. This information can be abused for social engineering attacks against users of the site or to find out the organizational structure of the company. User enumeration attacks are performed by entering an existing and a non-existing user into the email address field of the login form. If the system returns a different response or behaves differently depending on whether the user exists, the attacker can enter unknown email addresses and use the different behavior as a clue for the (non-)existing user. Impact Under normal circumstances, entering an invalid email address results in a "fake" login code form…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-43qq-qw4x-28f8

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-39314

Advisory: Kirby CMS vulnerable to user enumeration in the code-based login and password reset forms
IDs: CVE-2022-39314, GHSA-43qq-qw4x-28f8
Record: https://patchnext.com/advisories/cve-2022-39314 (revision 1, source checked 26 Oct 2026, 14:00 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: getkirby/cms 3.8.1, 3.7.5.1, 3.6.6.2, 3.5.8.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist getkirby/cms: affected >= 3.5.0, < 3.5.8.2; >= 3.6.0, < 3.6.6.2; >= 3.7.0, < 3.7.5.1; >= 3.8.0, <= 3.8.0; fixed in 3.8.1, 3.7.5.1, 3.6.6.2, 3.5.8.2

## Suggested inspection (read-only)
- Packagist getkirby/cms: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on getkirby/cms.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-43qq-qw4x-28f8 (GitHub-reviewed advisory GHSA-43qq-qw4x-28f8 lists affected ranges: Packagist getkirby/cms >=3.5.0 =3.6.0 =3.7.0 =3.8.0 <=3.8.0)

Commands are suggestions: review each one before running it.

Loading voting…