Skip to content

← Actionable
High, CVSS 7.5amended

parse-server crashes when receiving file download request with invalid byte range

CVE-2022-39313GHSA-h423-w6qv-2wj3

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (parse-server 5.2.8, 4.10.17), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm parse-server

    Affected
    < 4.10.17>= 5.0.0, < 5.2.8
    Fixed in
    5.2.8, 4.10.17

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2022-39313: 0.81% estimated exploitation activity in the next 30 days; percentile 57.08 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Parse Server crashes when a file download request is received with an invalid byte range. Patches Improved parsing of the range parameter to properly handle invalid range requests. Workarounds None References - GHSA-h423-w6qv-2wj3

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-h423-w6qv-2wj3

  2. Revision 1 · created ·

    Published from osv record GHSA-h423-w6qv-2wj3

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-39313

Advisory: parse-server crashes when receiving file download request with invalid byte range
IDs: CVE-2022-39313, GHSA-h423-w6qv-2wj3
Record: https://patchnext.com/advisories/cve-2022-39313 (revision 2, source checked 26 Oct 2026, 12:26 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: parse-server 5.2.8, 4.10.17. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm parse-server: affected < 4.10.17; >= 5.0.0, < 5.2.8; fixed in 5.2.8, 4.10.17

## Suggested inspection (read-only)
- `npm ls parse-server --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on parse-server.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-h423-w6qv-2wj3 (OSV record GHSA-h423-w6qv-2wj3 lists affected ranges: npm parse-server >=0 =5.0.0 <5.2.8 (fixed))
- Verified: https://github.com/advisories/GHSA-h423-w6qv-2wj3 (GitHub-reviewed advisory GHSA-h423-w6qv-2wj3 lists affected ranges: npm parse-server >=0 =5.0.0 <5.2.8)

Commands are suggestions: review each one before running it.

Loading voting…