Signature bypass via multiple root elements
CVE-2022-39300GHSA-5p8w-2mvw-38pv
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (node-saml 4.0.0-beta.5), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm node-saml
- Affected
- < 4.0.0-beta.5
- Fixed in
- 4.0.0-beta.5
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-5p8w-2mvw-38pv lists affected ranges: npm node-saml >=0 <4.0.0-beta.5 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-5p8w-2mvw-38pv lists affected ranges: npm node-saml >=0 <4.0.0-beta.5
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.1 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2022-39300: 0.78% estimated exploitation activity in the next 30 days; percentile 56.04 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact A remote attacker may be able to bypass SAML authentication on a website using passport-saml. A successful attack requires that the attacker is in possession of an arbitrary IDP signed XML element. Depending on the IDP used, fully unauthenticated attacks (e.g without access to a valid user) might also be feasible if generation of a signed message can be triggered. Patches Users should upgrade to node-saml v4.0.0-beta5 or newer. Workarounds Disable SAML authentication. References Are there any links users can visit to find out more? For more information If you have any questions or comments about this advisory: Open a discussion in the node-saml repo Credits Felix Wilhelm of Google Project Zero
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-5p8w-2mvw-38pv
- Revision 1 · created ·
Published from osv record GHSA-5p8w-2mvw-38pv
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-39300 Advisory: Signature bypass via multiple root elements IDs: CVE-2022-39300, GHSA-5p8w-2mvw-38pv Record: https://patchnext.com/advisories/cve-2022-39300 (revision 2, source checked 26 Oct 2026, 12:16 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: node-saml 4.0.0-beta.5. A vendor fix does not mean a deployment is fixed. ## Affected components - npm node-saml: affected < 4.0.0-beta.5; fixed in 4.0.0-beta.5 ## Suggested inspection (read-only) - `npm ls node-saml --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on node-saml. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-5p8w-2mvw-38pv (OSV record GHSA-5p8w-2mvw-38pv lists affected ranges: npm node-saml >=0 <4.0.0-beta.5 (fixed)) - Verified: https://github.com/advisories/GHSA-5p8w-2mvw-38pv (GitHub-reviewed advisory GHSA-5p8w-2mvw-38pv lists affected ranges: npm node-saml >=0 <4.0.0-beta.5) Commands are suggestions: review each one before running it.
Loading voting…