melisplatform/melis-front vulnerable to deserialization of untrusted data
CVE-2022-39298GHSA-h479-2mv4-5c26
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (melisplatform/melis-front 5.0.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist melisplatform/melis-front
- Affected
- < 5.0.1
- Fixed in
- 5.0.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-h479-2mv4-5c26 lists affected ranges: Packagist melisplatform/melis-front >=0 <5.0.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.7 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:L
- EPSS
- CVE-2022-39298: 1.27% estimated exploitation activity in the next 30 days; percentile 69.80 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Attackers can deserialize arbitrary data on affected versions of melisplatform/melis-front, and ultimately leads to the execution of arbitrary PHP code on the system. Conducting this attack does not require authentication. Users should immediately upgrade to melisplatform/melis-front = 5.0.1. Patches This issue was addressed by restricting allowed classes when deserializing user-controlled data. References - https://github.com/melisplatform/melis-front/commit/89ae612d5f1f7aa2fb621ee8de27dffe1feb851e For more information If you have any questions or comments about this advisory, you can contact: - The original reporters, by sending an email to vulnerability.research [at] sonarsource.com; - The maintainers, by opening an issue on this repository.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-h479-2mv4-5c26
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-39298 Advisory: melisplatform/melis-front vulnerable to deserialization of untrusted data IDs: CVE-2022-39298, GHSA-h479-2mv4-5c26 Record: https://patchnext.com/advisories/cve-2022-39298 (revision 1, source checked 26 Oct 2026, 14:00 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: melisplatform/melis-front 5.0.1. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist melisplatform/melis-front: affected < 5.0.1; fixed in 5.0.1 ## Suggested inspection (read-only) - Packagist melisplatform/melis-front: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on melisplatform/melis-front. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-h479-2mv4-5c26 (GitHub-reviewed advisory GHSA-h479-2mv4-5c26 lists affected ranges: Packagist melisplatform/melis-front >=0 <5.0.1) Commands are suggestions: review each one before running it.
Loading voting…