Skip to content

← Actionable
High, CVSS 7.5

conduit-hyper vulnerable to Denial of Service from unchecked request length

CVE-2022-39294GHSA-9398-5ghf-7pr6

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (conduit-hyper 0.4.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • crates.io conduit-hyper

    Affected
    >= 0.2.0-alpha.3, < 0.4.2
    Fixed in
    0.4.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2022-39294: 0.81% estimated exploitation activity in the next 30 days; percentile 57.08 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Prior to version 0.4.2, conduit-hyper did not check any limit on a request's length before calling hyper::body::tobytes. An attacker could send a malicious request with an abnormally large Content-Length, which could lead to a panic if memory allocation failed for that request. In version 0.4.2, conduit-hyper sets an internal limit of 128 MiB per request, otherwise returning status 400 ("Bad Request"). This crate is part of the implementation of Rust's crates.io, but that service is not affected due to its existing cloud infrastructure, which already drops such malicious requests. Even with the new limit in place, conduit-hyper is not recommended for production use, nor to directly serve the public Internet. The vulnerability was discovered by Ori Hollander from the JFrog Security Research team.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-9398-5ghf-7pr6

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-39294

Advisory: conduit-hyper vulnerable to Denial of Service from unchecked request length
IDs: CVE-2022-39294, GHSA-9398-5ghf-7pr6
Record: https://patchnext.com/advisories/cve-2022-39294 (revision 1, source checked 26 Oct 2026, 15:37 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: conduit-hyper 0.4.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- crates.io conduit-hyper: affected >= 0.2.0-alpha.3, < 0.4.2; fixed in 0.4.2

## Suggested inspection (read-only)
- crates.io conduit-hyper: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on conduit-hyper.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-9398-5ghf-7pr6 (GitHub-reviewed advisory GHSA-9398-5ghf-7pr6 lists affected ranges: crates.io conduit-hyper >=0.2.0-alpha.3 <0.4.2)

Commands are suggestions: review each one before running it.

Loading voting…