Skip to content

← Actionable
High, CVSS 7.5amended

fastify vulnerable to denial of service via malicious Content-Type

CVE-2022-39288GHSA-455w-c45v-86rg

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (fastify 4.8.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm fastify

    Affected
    >= 4.0.0, < 4.8.1
    Fixed in
    4.8.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2022-39288: 59.24% estimated exploitation activity in the next 30 days; percentile 99.12 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact An attacker can send an invalid Content-Type header that can cause the application to crash, leading to a possible Denial of Service attack. Only the v4.x line is affected. (This was updated: upon a close inspection, v3.x is not affected after all). Patches Yes, update to v4.8.0. Workarounds You can reject the malicious content types before the body parser enters in action. References See the HackerOne report #1715536 For more information Fastify security policy

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-455w-c45v-86rg

  2. Revision 1 · created ·

    Published from osv record GHSA-455w-c45v-86rg

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-39288

Advisory: fastify vulnerable to denial of service via malicious Content-Type
IDs: CVE-2022-39288, GHSA-455w-c45v-86rg
Record: https://patchnext.com/advisories/cve-2022-39288 (revision 2, source checked 26 Oct 2026, 12:21 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: fastify 4.8.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm fastify: affected >= 4.0.0, < 4.8.1; fixed in 4.8.1

## Suggested inspection (read-only)
- `npm ls fastify --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on fastify.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-455w-c45v-86rg (OSV record GHSA-455w-c45v-86rg lists affected ranges: npm fastify >=4.0.0 <4.8.1 (fixed))
- Verified: https://github.com/advisories/GHSA-455w-c45v-86rg (GitHub-reviewed advisory GHSA-455w-c45v-86rg lists affected ranges: npm fastify >=4.0.0 <4.8.1)

Commands are suggestions: review each one before running it.

Loading voting…