Codeigniter4's Secure or HttpOnly flag set in Config\Cookie is not reflected in Cookies issued
CVE-2022-39284GHSA-745p-r637-7vvp
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (codeigniter4/framework 4.2.7), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist codeigniter4/framework
- Affected
- < 4.2.7
- Fixed in
- 4.2.7
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-745p-r637-7vvp lists affected ranges: Packagist codeigniter4/framework >=0 <4.2.7
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 2.6 · CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:L/I:N/A:N
- EPSS
- CVE-2022-39284: 1.12% estimated exploitation activity in the next 30 days; percentile 66.25 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Setting $secure or $httponly value to true in Config\Cookie is not reflected in setcookie() or Response::setCookie(). Note This vulnerability does not affect session cookies. The following code does not issue a cookie with the secure flag even if you set $secure = true in Config\Cookie. Patches Upgrade to v4.2.7 or later. Workarounds 1. Specify the options explicitly. 2. Use Cookie object. References - https://codeigniter4.github.io/userguide/helpers/cookiehelper.html#setcookie - https://codeigniter4.github.io/userguide/outgoing/response.html#CodeIgniter\HTTP\Response::setCookie For more information If you have any questions or comments about this advisory: Open an issue in codeigniter4/CodeIgniter4 Email us at SECURITY.md
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-745p-r637-7vvp
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-39284 Advisory: Codeigniter4's Secure or HttpOnly flag set in Config\Cookie is not reflected in Cookies issued IDs: CVE-2022-39284, GHSA-745p-r637-7vvp Record: https://patchnext.com/advisories/cve-2022-39284 (revision 1, source checked 26 Oct 2026, 14:06 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 2.6) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: codeigniter4/framework 4.2.7. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist codeigniter4/framework: affected < 4.2.7; fixed in 4.2.7 ## Suggested inspection (read-only) - Packagist codeigniter4/framework: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on codeigniter4/framework. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-745p-r637-7vvp (GitHub-reviewed advisory GHSA-745p-r637-7vvp lists affected ranges: Packagist codeigniter4/framework >=0 <4.2.7) Commands are suggestions: review each one before running it.
Loading voting…