ReDoS issue in dparse
CVE-2022-39280GHSA-8fg9-p83m-x5pq
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (dparse 0.5.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI dparse
- Affected
- < 0.5.2
- Fixed in
- 0.5.2
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-8fg9-p83m-x5pq lists affected ranges: PyPI dparse >=0 <0.5.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-8fg9-p83m-x5pq lists affected ranges: PyPI dparse >=0 <0.5.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.2 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2022-39280: 1.34% estimated exploitation activity in the next 30 days; percentile 71.26 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact dparse versions prior to 0.5.1 contain a regular expression that is vulnerable to ReDoS (Regular Expression Denial of Service). All users parsing index server URLs with dparse are impacted by this vulnerability. Patches The Patch is applied in the 0.5.2 version, all users are recommended to upgrade as soon as possible. Workarounds Avoid passing index server URLs in the source file to be parsed. References https://github.com/pyupio/dparse/tree/security/remove-intensive-regex For more information If you have any questions or comments about this advisory: Email us at support@pyup.io
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-8fg9-p83m-x5pq
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-8fg9-p83m-x5pq
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-39280 Advisory: ReDoS issue in dparse IDs: CVE-2022-39280, GHSA-8fg9-p83m-x5pq Record: https://patchnext.com/advisories/cve-2022-39280 (revision 3, source checked 26 Oct 2026, 13:27 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.2) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: dparse 0.5.2. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI dparse: affected < 0.5.2; fixed in 0.5.2 ## Suggested inspection (read-only) - `python -m pip show dparse`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on dparse. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-8fg9-p83m-x5pq (OSV record GHSA-8fg9-p83m-x5pq lists affected ranges: PyPI dparse >=0 <0.5.2 (fixed)) - Verified: https://github.com/advisories/GHSA-8fg9-p83m-x5pq (GitHub-reviewed advisory GHSA-8fg9-p83m-x5pq lists affected ranges: PyPI dparse >=0 <0.5.2) Commands are suggestions: review each one before running it.
Loading voting…