Skip to content

← Actionable
High, CVSS 7.5

FlyteAdmin's Default OAuth Authorization Server secret must be rotated

CVE-2022-39273GHSA-67x4-qr35-qvrm

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/flyteorg/flyteadmin 1.1.44), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
EPSS
  • CVE-2022-39273: 0.93% estimated exploitation activity in the next 30 days; percentile 60.53 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Users who enable the default Flyte’s authorization server without changing the default clientid hashes will be exposed to the public internet. In an effort to make enabling authentication easier for Flyte administrators, the default configuration for Flyte Admin allows access for Flyte Propeller even after turning on authentication via a hardcoded hashed password. This password is also set on the default Flyte Propeller configmap in the various Flyte Helm charts. Users who enable auth but do not override this setting in Flyte Admin’s configuration may unknowingly allow public traffic in by way of this default password with attackers effectively impersonating propeller. This only applies to users who have not specified the ExternalAuthorizationServer setting. Using an external auth server automatically turns off this default configuration is not susceptible to this vulnerability. Patches 1.1.44 Workarounds Users should manually set the staticClients in the selfAuthServer…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-67x4-qr35-qvrm

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-39273

Advisory: FlyteAdmin's Default OAuth Authorization Server secret must be rotated
IDs: CVE-2022-39273, GHSA-67x4-qr35-qvrm
Record: https://patchnext.com/advisories/cve-2022-39273 (revision 1, source checked 26 Oct 2026, 15:04 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/flyteorg/flyteadmin 1.1.44. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/flyteorg/flyteadmin: affected < 1.1.44; fixed in 1.1.44

## Suggested inspection (read-only)
- Go github.com/flyteorg/flyteadmin: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/flyteorg/flyteadmin.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-67x4-qr35-qvrm (GitHub-reviewed advisory GHSA-67x4-qr35-qvrm lists affected ranges: Go github.com/flyteorg/flyteadmin >=0 <1.1.44)

Commands are suggestions: review each one before running it.

Loading voting…