Bifrost vulnerable to authentication check flaw that leads to authentication bypass
CVE-2022-39267GHSA-mxrx-fg8p-5p5j
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/brokercap/Bifrost 1.8.7-release), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go github.com/brokercap/Bifrost
- Affected
- < 1.8.7-release
- Fixed in
- 1.8.7-release
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-mxrx-fg8p-5p5j lists affected ranges: Go github.com/brokercap/Bifrost >=0 <1.8.7-release
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.8 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2022-39267: 0.88% estimated exploitation activity in the next 30 days; percentile 59.11 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact The admin and monitor user groups need to be authenticated by username and password. If we delete the X-Requested-With: XMLHttpRequest field in the request header,the authentication will be bypassed. Patches https://github.com/brockercap/Bifrost/pull/201 Workarounds Upgrade to the latest version
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-mxrx-fg8p-5p5j
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-39267 Advisory: Bifrost vulnerable to authentication check flaw that leads to authentication bypass IDs: CVE-2022-39267, GHSA-mxrx-fg8p-5p5j Record: https://patchnext.com/advisories/cve-2022-39267 (revision 1, source checked 26 Oct 2026, 14:55 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/brokercap/Bifrost 1.8.7-release. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/brokercap/Bifrost: affected < 1.8.7-release; fixed in 1.8.7-release ## Suggested inspection (read-only) - Go github.com/brokercap/Bifrost: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/brokercap/Bifrost. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-mxrx-fg8p-5p5j (GitHub-reviewed advisory GHSA-mxrx-fg8p-5p5j lists affected ranges: Go github.com/brokercap/Bifrost >=0 <1.8.7-release) Commands are suggestions: review each one before running it.
Loading voting…