Upstash Adapter missing token verification
CVE-2022-39263GHSA-4rxr-27mm-mxq9
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@next-auth/upstash-redis-adapter 3.0.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm @next-auth/upstash-redis-adapter
- Affected
- < 3.0.2
- Fixed in
- 3.0.2
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-4rxr-27mm-mxq9 lists affected ranges: npm @next-auth/upstash-redis-adapter >=0 <3.0.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-4rxr-27mm-mxq9 lists affected ranges: npm @next-auth/upstash-redis-adapter >=0 <3.0.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.8 · CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:N
- EPSS
- CVE-2022-39263: 0.72% estimated exploitation activity in the next 30 days; percentile 54.02 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Applications that use next-auth Email Provider and @next-auth/upstash-redis-adapter before v3.0.2 are affected. Description The Upstash Redis adapter implementation did not check for both the identifier (email) and the token, but only checking for the identifier when verifying the token in the email callback flow. An attacker who knows about the victim's email could easily sign in as the victim, given the attacker also knows about the verification token's expired duration. Patches The vulnerability is patched in v3.0.2. To upgrade, run one of the following: Workarounds Using Advanced Initialization, developers can check the requests and compare the query's token and identifier before proceeding. Below is an example of how to do this: (Upgrading is still strongly recommended) References EmailProvider: https://next-auth.js.org/providers/email Advanced Initialization: https://next-auth.js.org/configuration/initialization#advanced-initialization Upstash Redis Adapter:…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-4rxr-27mm-mxq9
- Revision 1 · created ·
Published from osv record GHSA-4rxr-27mm-mxq9
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-39263 Advisory: Upstash Adapter missing token verification IDs: CVE-2022-39263, GHSA-4rxr-27mm-mxq9 Record: https://patchnext.com/advisories/cve-2022-39263 (revision 2, source checked 26 Oct 2026, 12:17 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @next-auth/upstash-redis-adapter 3.0.2. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @next-auth/upstash-redis-adapter: affected < 3.0.2; fixed in 3.0.2 ## Suggested inspection (read-only) - `npm ls @next-auth/upstash-redis-adapter --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @next-auth/upstash-redis-adapter. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-4rxr-27mm-mxq9 (OSV record GHSA-4rxr-27mm-mxq9 lists affected ranges: npm @next-auth/upstash-redis-adapter >=0 <3.0.2 (fixed)) - Verified: https://github.com/advisories/GHSA-4rxr-27mm-mxq9 (GitHub-reviewed advisory GHSA-4rxr-27mm-mxq9 lists affected ranges: npm @next-auth/upstash-redis-adapter >=0 <3.0.2) Commands are suggestions: review each one before running it.
Loading voting…