Twig may load a template outside a configured directory when using the filesystem loader
CVE-2022-39261GHSA-52m2-vc4m-jj33
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (twig/twig 3.4.3, 2.15.3, 1.44.7), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist twig/twig
- Affected
- >= 1.0.0, < 1.44.7>= 2.0.0, < 2.15.3>= 3.0.0, < 3.4.3
- Fixed in
- 2.15.3, 1.44.7, 3.4.3
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-52m2-vc4m-jj33 lists affected ranges: Packagist twig/twig >=1.0.0 =2.0.0 =3.0.0 <3.4.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
- EPSS
- CVE-2022-39261: 3.17% estimated exploitation activity in the next 30 days; percentile 88.06 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Description When using the filesystem loader to load templates for which the name is a user input, it is possible to use the source or include statement to read arbitrary files from outside the templates directory when using a namespace like @somewhere/../some.file (in such a case, validation is bypassed). Resolution We fixed validation for such template names. Even if the 1.x branch is not maintained anymore, a new version has been released. Credits We would like to thank Dariusz Tytko for reporting the issue and Fabien Potencier for fixing the issue.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-52m2-vc4m-jj33
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-39261 Advisory: Twig may load a template outside a configured directory when using the filesystem loader IDs: CVE-2022-39261, GHSA-52m2-vc4m-jj33 Record: https://patchnext.com/advisories/cve-2022-39261 (revision 1, source checked 26 Oct 2026, 13:59 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: twig/twig 3.4.3, 2.15.3, 1.44.7. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist twig/twig: affected >= 1.0.0, < 1.44.7; >= 2.0.0, < 2.15.3; >= 3.0.0, < 3.4.3; fixed in 2.15.3, 1.44.7, 3.4.3 ## Suggested inspection (read-only) - Packagist twig/twig: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on twig/twig. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-52m2-vc4m-jj33 (GitHub-reviewed advisory GHSA-52m2-vc4m-jj33 lists affected ranges: Packagist twig/twig >=1.0.0 =2.0.0 =3.0.0 <3.4.3) Commands are suggestions: review each one before running it.
Loading voting…