Skip to content

← Actionable
Medium, CVSS 6.5amended

fhir-works-on-aws-authz-smart handles permissions improperly

CVE-2022-39230GHSA-vv7x-7w4m-q72f

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (fhir-works-on-aws-authz-smart 3.1.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
EPSS
  • CVE-2022-39230: 0.74% estimated exploitation activity in the next 30 days; percentile 54.74 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact This issue allows a client of the API to retrieve more information than the client’s OAuth scope permits when making “search-type” requests. This issue would not allow a client to retrieve information about individuals other than those the client was already authorized to access. Patches We recommend that users of fhir-works-on-aws-authz-smart 3.1.1 or 3.1.2 upgrade to version 3.1.3 or higher immediately. Versions 3.1.0 and below are unaffected. Workarounds There is no workaround for this issue. Please upgrade fhir-works-on-aws-authz-smart to version 3.1.3 or higher. References https://github.com/awslabs/fhir-works-on-aws-deployment https://github.com/awslabs/fhir-works-on-aws-authz-smart For more information If you have any questions or comments about this advisory: Email us at fhir-works-on-aws-dev@amazon.com

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-vv7x-7w4m-q72f

  2. Revision 1 · created ·

    Published from osv record GHSA-vv7x-7w4m-q72f

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-39230

Advisory: fhir-works-on-aws-authz-smart handles permissions improperly
IDs: CVE-2022-39230, GHSA-vv7x-7w4m-q72f
Record: https://patchnext.com/advisories/cve-2022-39230 (revision 2, source checked 26 Oct 2026, 12:16 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: fhir-works-on-aws-authz-smart 3.1.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm fhir-works-on-aws-authz-smart: affected >= 3.1.1, < 3.1.3; fixed in 3.1.3

## Suggested inspection (read-only)
- `npm ls fhir-works-on-aws-authz-smart --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on fhir-works-on-aws-authz-smart.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-vv7x-7w4m-q72f (OSV record GHSA-vv7x-7w4m-q72f lists affected ranges: npm fhir-works-on-aws-authz-smart >=3.1.1 <3.1.3 (fixed))
- Verified: https://github.com/advisories/GHSA-vv7x-7w4m-q72f (GitHub-reviewed advisory GHSA-vv7x-7w4m-q72f lists affected ranges: npm fhir-works-on-aws-authz-smart >=3.1.1 <3.1.3)

Commands are suggestions: review each one before running it.

Loading voting…