python-jwt vulnerable to token forgery with new claims
CVE-2022-39227GHSA-5p8v-58qm-c7fp
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (python-jwt 3.3.4), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI python-jwt
- Affected
- < 3.3.4
- Fixed in
- 3.3.4
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-5p8v-58qm-c7fp lists affected ranges: PyPI python-jwt >=0 <3.3.4 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-5p8v-58qm-c7fp lists affected ranges: PyPI python-jwt >=0 <3.3.4
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 9.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2022-39227: 5.34% estimated exploitation activity in the next 30 days; percentile 92.64 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact An attacker who obtains a JWT can arbitrarily forge its contents without knowing the secret key. Depending on the application, this may for example enable the attacker to spoof other user's identities, hijack their sessions, or bypass authentication. Patches Users should upgrade to version 3.3.4 Fixed by: https://github.com/davedoesdev/python-jwt/commit/88ad9e67c53aa5f7c43ec4aa52ed34b7930068c9 Workarounds None References Found by Tom Tervoort https://github.com/pypa/advisory-database/blob/main/vulns/python-jwt/PYSEC-2022-259.yaml More information The vulnerability allows an attacker, who possesses a single valid JWT, to create a new token with forged claims that the verifyjwt function will accept as valid. The issue is caused by an inconsistency between the JWT parsers used by python-jwt and its dependency jwcrypto. By mixing compact and JSON representations, an attacker can trick jwcrypto of parsing different claims than those over which a signature is validated by jwcrypto.…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-5p8v-58qm-c7fp
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-5p8v-58qm-c7fp
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-39227 Advisory: python-jwt vulnerable to token forgery with new claims IDs: CVE-2022-39227, GHSA-5p8v-58qm-c7fp Record: https://patchnext.com/advisories/cve-2022-39227 (revision 3, source checked 26 Oct 2026, 13:16 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: python-jwt 3.3.4. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI python-jwt: affected < 3.3.4; fixed in 3.3.4 ## Suggested inspection (read-only) - `python -m pip show python-jwt`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on python-jwt. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-5p8v-58qm-c7fp (OSV record GHSA-5p8v-58qm-c7fp lists affected ranges: PyPI python-jwt >=0 <3.3.4 (fixed)) - Verified: https://github.com/advisories/GHSA-5p8v-58qm-c7fp (GitHub-reviewed advisory GHSA-5p8v-58qm-c7fp lists affected ranges: PyPI python-jwt >=0 <3.3.4) Commands are suggestions: review each one before running it.
Loading voting…