parse-server's session object properties can be updated by foreign user if object ID is known
CVE-2022-39225GHSA-6w4q-23cf-j9jp
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (parse-server 5.2.6, 4.10.15), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm parse-server
- Affected
- < 4.10.15>= 5.0.0, < 5.2.6
- Fixed in
- 4.10.15, 5.2.6
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-6w4q-23cf-j9jp lists affected ranges: npm parse-server >=0 =5.0.0 <5.2.6 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-6w4q-23cf-j9jp lists affected ranges: npm parse-server >=0 =5.0.0 <5.2.6
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 4.3 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N
- EPSS
- CVE-2022-39225: 0.49% estimated exploitation activity in the next 30 days; percentile 42.11 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact A foreign user can write to the session object of another user if the session object ID is known. For example, a foreign user can assign the session object to their own user by writing to the user field and then read any custom fields of that session object. Note that assigning a session to a foreign user does not usually change the privileges of neither of the two users, according to how Parse Server uses session objects internally. However, if custom logic is used to relate specific session objects to privileges this vulnerability may have a higher level of severity. The vulnerability does not allow a foreign user to assign a session object to themselves, read the session token, and then reassign the session object to the original user to then authenticate as that user with the known session token. The vulnerability only exists for foreign session objects, a user cannot assign their own session to another user. While it is unlikely that the session object ID of another user…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-6w4q-23cf-j9jp
- Revision 1 · created ·
Published from osv record GHSA-6w4q-23cf-j9jp
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-39225 Advisory: parse-server's session object properties can be updated by foreign user if object ID is known IDs: CVE-2022-39225, GHSA-6w4q-23cf-j9jp Record: https://patchnext.com/advisories/cve-2022-39225 (revision 2, source checked 26 Oct 2026, 12:16 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 4.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: parse-server 5.2.6, 4.10.15. A vendor fix does not mean a deployment is fixed. ## Affected components - npm parse-server: affected < 4.10.15; >= 5.0.0, < 5.2.6; fixed in 4.10.15, 5.2.6 ## Suggested inspection (read-only) - `npm ls parse-server --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on parse-server. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-6w4q-23cf-j9jp (OSV record GHSA-6w4q-23cf-j9jp lists affected ranges: npm parse-server >=0 =5.0.0 <5.2.6 (fixed)) - Verified: https://github.com/advisories/GHSA-6w4q-23cf-j9jp (GitHub-reviewed advisory GHSA-6w4q-23cf-j9jp lists affected ranges: npm parse-server >=0 =5.0.0 <5.2.6) Commands are suggestions: review each one before running it.
Loading voting…