arr-pm vulnerable to arbitrary shell execution when extracting or listing files contained in a malicious rpm.
CVE-2022-39224GHSA-88cv-mj24-8w3q
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (arr-pm 0.0.12), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
RubyGems arr-pm
- Affected
- < 0.0.12
- Fixed in
- 0.0.12
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-88cv-mj24-8w3q lists affected ranges: RubyGems arr-pm >=0 <0.0.12
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.0 · CVSS:3.1/AV:L/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H
- EPSS
- CVE-2022-39224: 1.46% estimated exploitation activity in the next 30 days; percentile 73.53 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Arbitrary shell execution is possible when using RPM::File#files and RPM::File#extract if the RPM contains a malicious "payload compressor" field. This vulnerability impacts the extract and files methods of the RPM::File class in the affected versions of this library. Patches Version 0.0.12 is available with a fix for these issues. Workarounds When using an affected version of this library (arr-pm), ensure any RPMs being processed contain valid/known payload compressor values. Such values include: gzip, bzip2, xz, zstd, and lzma. You can check the payload compressor field in an rpm by using the rpm command line tool. For example: Impact on known dependent projects This library is used by fpm. The vulnerability may impact fpm only when using the flag -s rpm or --input-type rpm to convert a malicious rpm to another format. It does not impact creating rpms. References https://github.com/jordansissel/ruby-arr-pm/pull/14 https://github.com/jordansissel/ruby-arr-pm/pull/15 Credit…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-88cv-mj24-8w3q
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-39224 Advisory: arr-pm vulnerable to arbitrary shell execution when extracting or listing files contained in a malicious rpm. IDs: CVE-2022-39224, GHSA-88cv-mj24-8w3q Record: https://patchnext.com/advisories/cve-2022-39224 (revision 1, source checked 26 Oct 2026, 15:44 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.0) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: arr-pm 0.0.12. A vendor fix does not mean a deployment is fixed. ## Affected components - RubyGems arr-pm: affected < 0.0.12; fixed in 0.0.12 ## Suggested inspection (read-only) - RubyGems arr-pm: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on arr-pm. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-88cv-mj24-8w3q (GitHub-reviewed advisory GHSA-88cv-mj24-8w3q lists affected ranges: RubyGems arr-pm >=0 <0.0.12) Commands are suggestions: review each one before running it.
Loading voting…