Skip to content

← Actionable
Critical, CVSS 9.3

Dex vulnerable to Man-in-the-Middle allowing ID token capture via intercepted authorization code

CVE-2022-39222GHSA-vh7g-p26c-j2cw

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/dexidp/dex 2.35.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:N
EPSS
  • CVE-2022-39222: 1.58% estimated exploitation activity in the next 30 days; percentile 75.60 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Dex instances with public clients (and by extension, clients accepting tokens issued by those Dex instances) are affected by this vulnerability. An attacker can exploit this vulnerability by making a victim navigate to a malicious website and guiding them through the OIDC flow, stealing the OAuth authorization code in the process. The authorization code then can be exchanged by the attacker for a token, gaining access to applications accepting that token. Steps to reproduce 1) A victim navigates to a malicious website 2) The webserver initiates a connection with a Dex instance directly - https://dexexample.com/auth/https:%252F%252Faccounts.google.com?accesstype=online&clientid=example&nonce=2AaJAimQU9CbeOFsNra1d7CJTWB&redirecturi=http%3A%2F%2Flocalhost%3A40393%2Fauth%2Fcallback&responsetype=code&scope=openid+email&state=2AaJAjhpUmsB25csCo5muvorMTl. In this example, the Dex instance is hosted on dexexample.com, and the connector is accounts.google.com. 3) Dex returns a 302…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-vh7g-p26c-j2cw

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-39222

Advisory: Dex vulnerable to Man-in-the-Middle allowing ID token capture via intercepted authorization code
IDs: CVE-2022-39222, GHSA-vh7g-p26c-j2cw
Record: https://patchnext.com/advisories/cve-2022-39222 (revision 1, source checked 26 Oct 2026, 14:58 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/dexidp/dex 2.35.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/dexidp/dex: affected <= 2.34.0; fixed in 2.35.0

## Suggested inspection (read-only)
- Go github.com/dexidp/dex: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/dexidp/dex.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-vh7g-p26c-j2cw (GitHub-reviewed advisory GHSA-vh7g-p26c-j2cw lists affected ranges: Go github.com/dexidp/dex >=0 <=2.34.0)

Commands are suggestions: review each one before running it.

Loading voting…