decode-uri-component vulnerable to Denial of Service (DoS)
CVE-2022-38900GHSA-w573-4hg7-7wgq
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (decode-uri-component 0.2.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- < 0.2.1
- Fixed in
- 0.2.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-w573-4hg7-7wgq lists affected ranges: npm decode-uri-component >=0 <0.2.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-w573-4hg7-7wgq lists affected ranges: npm decode-uri-component >=0 <0.2.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2022-38900: 23.61% estimated exploitation activity in the next 30 days; percentile 97.81 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
decode-uri-component 0.2.0 is vulnerable to Improper Input Validation resulting in DoS.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-w573-4hg7-7wgq
- Revision 1 · created ·
Published from osv record GHSA-w573-4hg7-7wgq
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-38900 Advisory: decode-uri-component vulnerable to Denial of Service (DoS) IDs: CVE-2022-38900, GHSA-w573-4hg7-7wgq Record: https://patchnext.com/advisories/cve-2022-38900 (revision 2, source checked 26 Oct 2026, 12:26 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: decode-uri-component 0.2.1. A vendor fix does not mean a deployment is fixed. ## Affected components - npm decode-uri-component: affected < 0.2.1; fixed in 0.2.1 ## Suggested inspection (read-only) - `npm ls decode-uri-component --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on decode-uri-component. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-w573-4hg7-7wgq (OSV record GHSA-w573-4hg7-7wgq lists affected ranges: npm decode-uri-component >=0 <0.2.1 (fixed)) - Verified: https://github.com/advisories/GHSA-w573-4hg7-7wgq (GitHub-reviewed advisory GHSA-w573-4hg7-7wgq lists affected ranges: npm decode-uri-component >=0 <0.2.1) Commands are suggestions: review each one before running it.
Loading voting…