Skip to content

← Actionable
Medium, CVSS 6.5

snakeYAML before 1.31 vulnerable to Denial of Service due to Out-of-bounds Write

CVE-2022-38749GHSA-c4r9-r8fh-9vj2

What to do

Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Maven org.yaml:snakeyaml

    Affected
    < 1.31
    Fixed in
    1.31
  • Maven io.prometheus.jmx:jmx_prometheus_httpserver

    Affected
    >= 0.17.0, <= 0.17.0
    Fixed in
    no fixed version recorded
  • Maven com.alipay.sofa.acts:acts-common-util

    Affected
    >= 1.0.0, <= 1.0.0
    Fixed in
    no fixed version recorded
  • Maven org.testifyproject.external:external-snakeyaml

    Affected
    <= 1.0.6
    Fixed in
    no fixed version recorded
  • Maven io.prometheus.jmx:jmx_prometheus_httpserver_java6

    Affected
    <= 0.18.0
    Fixed in
    no fixed version recorded
  • Maven pl.droidsonroids.yaml:snakeyaml

    Affected
    <= 1.18.2
    Fixed in
    no fixed version recorded
  • Maven be.cylab:snakeyaml

    Affected
    >= 1.25.1, <= 1.25.1
    Fixed in
    no fixed version recorded

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2022-38749: 2.20% estimated exploitation activity in the next 30 days; percentile 82.53 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Using snakeYAML to parse untrusted YAML files may be vulnerable to Denial of Service attacks (DOS). If the parser is running on user supplied input, an attacker may supply content that causes the parser to crash by stackoverflow.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-c4r9-r8fh-9vj2

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-38749

Advisory: snakeYAML before 1.31 vulnerable to Denial of Service due to Out-of-bounds Write
IDs: CVE-2022-38749, GHSA-c4r9-r8fh-9vj2
Record: https://patchnext.com/advisories/cve-2022-38749 (revision 1, source checked 26 Oct 2026, 16:29 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Partial vendor fix; fixed versions by package: org.yaml:snakeyaml 1.31. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.yaml:snakeyaml: affected < 1.31; fixed in 1.31
- Maven io.prometheus.jmx:jmx_prometheus_httpserver: affected >= 0.17.0, <= 0.17.0
- Maven com.alipay.sofa.acts:acts-common-util: affected >= 1.0.0, <= 1.0.0
- Maven org.testifyproject.external:external-snakeyaml: affected <= 1.0.6
- Maven io.prometheus.jmx:jmx_prometheus_httpserver_java6: affected <= 0.18.0
- Maven pl.droidsonroids.yaml:snakeyaml: affected <= 1.18.2
- Maven be.cylab:snakeyaml: affected >= 1.25.1, <= 1.25.1

## Suggested inspection (read-only)
- Maven org.yaml:snakeyaml: check the installed version with your package manager.
- Maven io.prometheus.jmx:jmx_prometheus_httpserver: check the installed version with your package manager.
- Maven com.alipay.sofa.acts:acts-common-util: check the installed version with your package manager.
- Maven org.testifyproject.external:external-snakeyaml: check the installed version with your package manager.
- Maven io.prometheus.jmx:jmx_prometheus_httpserver_java6: check the installed version with your package manager.
- Maven pl.droidsonroids.yaml:snakeyaml: check the installed version with your package manager.
- Maven be.cylab:snakeyaml: check the installed version with your package manager.

## Supported action
No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.yaml:snakeyaml, io.prometheus.jmx:jmx_prometheus_httpserver, com.alipay.sofa.acts:acts-common-util, org.testifyproject.external:external-snakeyaml, io.prometheus.jmx:jmx_prometheus_httpserver_java6, pl.droidsonroids.yaml:snakeyaml, be.cylab:snakeyaml.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-c4r9-r8fh-9vj2 (GitHub-reviewed advisory GHSA-c4r9-r8fh-9vj2 lists affected ranges: Maven org.yaml:snakeyaml >=0 =1.25.1 =1.0.0 =0.17.0 =0 =0 =0 <=1.18.2)

Commands are suggestions: review each one before running it.

Loading voting…