Skip to content

← Actionable
Critical, CVSS 9.8

Skipper vulnerable to SSRF via X-Skipper-Proxy

CVE-2022-38580GHSA-f2rj-m42r-6jm2

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/zalando/skipper 0.13.237), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2022-38580: 15.89% estimated exploitation activity in the next 30 days; percentile 96.89 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Skipper prior to version v0.13.236 is vulnerable to server-side request forgery (SSRF). An attacker can exploit a vulnerable version of proxy to access the internal metadata server or other unauthenticated URLs by adding an specific header (X-Skipper-Proxy) to the http request. Patches The problem was patched in version https://github.com/zalando/skipper/releases/tag/v0.13.237. Users need to upgrade to skipper =v0.13.237. Workarounds Use dropRequestHeader("X-Skipper-Proxy") filter References https://github.com/zalando/skipper/releases/tag/v0.13.237 For more information If you have any questions or comments about this advisory: Open an issue in https://github.com/zalando/skipper/issues/new/choose Chat with us in slack: https://app.slack.com/client/T029RQSE6/C82Q5JNH5

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-f2rj-m42r-6jm2

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-38580

Advisory: Skipper vulnerable to SSRF via X-Skipper-Proxy
IDs: CVE-2022-38580, GHSA-f2rj-m42r-6jm2
Record: https://patchnext.com/advisories/cve-2022-38580 (revision 1, source checked 26 Oct 2026, 14:58 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/zalando/skipper 0.13.237. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/zalando/skipper: affected < 0.13.237; fixed in 0.13.237

## Suggested inspection (read-only)
- Go github.com/zalando/skipper: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/zalando/skipper.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-f2rj-m42r-6jm2 (GitHub-reviewed advisory GHSA-f2rj-m42r-6jm2 lists affected ranges: Go github.com/zalando/skipper >=0 <0.13.237)

Commands are suggestions: review each one before running it.

Loading voting…