Centreon vulnerable to SQL Injection
CVE-2022-3827GHSA-j5wx-jvw3-j363
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (centreon/centreon 22.10.0-beta1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist centreon/centreon
- Affected
- < 22.10.0-beta1
- Fixed in
- 22.10.0-beta1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-j5wx-jvw3-j363 lists affected ranges: Packagist centreon/centreon >=0 <22.10.0-beta1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2022-3827: 1.02% estimated exploitation activity in the next 30 days; percentile 63.39 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
A SQL injection vulnerability in Centreon affects unknown code of the file formContactGroup.php of the component Contact Groups Form. The manipulation of the argument cgid leads to sql injection. The attack can be initiated remotely. Version 22.10.0-beta1 contains a patch for this issue.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-j5wx-jvw3-j363
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-3827 Advisory: Centreon vulnerable to SQL Injection IDs: CVE-2022-3827, GHSA-j5wx-jvw3-j363 Record: https://patchnext.com/advisories/cve-2022-3827 (revision 1, source checked 26 Oct 2026, 14:04 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: centreon/centreon 22.10.0-beta1. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist centreon/centreon: affected < 22.10.0-beta1; fixed in 22.10.0-beta1 ## Suggested inspection (read-only) - Packagist centreon/centreon: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on centreon/centreon. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-j5wx-jvw3-j363 (GitHub-reviewed advisory GHSA-j5wx-jvw3-j363 lists affected ranges: Packagist centreon/centreon >=0 <22.10.0-beta1) Commands are suggestions: review each one before running it.
Loading voting…