Blind SQL Injection via GridFieldSortableHeader
CVE-2022-38148GHSA-rr8h-f97q-8p9c
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (silverstripe/framework 4.11.14, 4.10.11), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist silverstripe/framework
- Affected
- >= 4.0.0, < 4.10.11>= 4.11.0, < 4.11.14
- Fixed in
- 4.10.11, 4.11.14
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-rr8h-f97q-8p9c lists affected ranges: Packagist silverstripe/framework >=4.0.0 =4.11.0 <4.11.14
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.8 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2022-38148: 0.80% estimated exploitation activity in the next 30 days; percentile 56.79 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Gridfield state is vulnerable to SQL injections. The vast majority of Gridfields in Silverstripe CMS are affected by this vulnerability. An attacker with CMS access could execute an arbitrary SQL statement by adding an SQL payload in some parts of the GridField state.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-rr8h-f97q-8p9c
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-38148 Advisory: Blind SQL Injection via GridFieldSortableHeader IDs: CVE-2022-38148, GHSA-rr8h-f97q-8p9c Record: https://patchnext.com/advisories/cve-2022-38148 (revision 1, source checked 26 Oct 2026, 14:33 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: silverstripe/framework 4.11.14, 4.10.11. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist silverstripe/framework: affected >= 4.0.0, < 4.10.11; >= 4.11.0, < 4.11.14; fixed in 4.10.11, 4.11.14 ## Suggested inspection (read-only) - Packagist silverstripe/framework: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on silverstripe/framework. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-rr8h-f97q-8p9c (GitHub-reviewed advisory GHSA-rr8h-f97q-8p9c lists affected ranges: Packagist silverstripe/framework >=4.0.0 =4.11.0 <4.11.14) Commands are suggestions: review each one before running it.
Loading voting…