node-red-dashboard vulnerable to Cross-site Scripting
CVE-2022-3783GHSA-vrv9-3x3w-ffxw
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (node-red-dashboard 3.2.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- < 3.2.0
- Fixed in
- 3.2.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-vrv9-3x3w-ffxw lists affected ranges: npm node-red-dashboard >=0 <3.2.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-vrv9-3x3w-ffxw lists affected ranges: npm node-red-dashboard >=0 <3.2.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- EPSS
- CVE-2022-3783: 0.83% estimated exploitation activity in the next 30 days; percentile 57.60 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
node-red-dashboard contains a cross-site scripting vulnerability. This issue affects some unknown processing of the file components/ui-component/ui-component-ctrl.js of the component uitext Format Handler. The attack may be initiated remotely. The issue is patched in version 3.2.0.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-vrv9-3x3w-ffxw
- Revision 1 · created ·
Published from osv record GHSA-vrv9-3x3w-ffxw
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-3783 Advisory: node-red-dashboard vulnerable to Cross-site Scripting IDs: CVE-2022-3783, GHSA-vrv9-3x3w-ffxw Record: https://patchnext.com/advisories/cve-2022-3783 (revision 2, source checked 26 Oct 2026, 12:20 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: node-red-dashboard 3.2.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm node-red-dashboard: affected < 3.2.0; fixed in 3.2.0 ## Suggested inspection (read-only) - `npm ls node-red-dashboard --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on node-red-dashboard. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-vrv9-3x3w-ffxw (OSV record GHSA-vrv9-3x3w-ffxw lists affected ranges: npm node-red-dashboard >=0 <3.2.0 (fixed)) - Verified: https://github.com/advisories/GHSA-vrv9-3x3w-ffxw (GitHub-reviewed advisory GHSA-vrv9-3x3w-ffxw lists affected ranges: npm node-red-dashboard >=0 <3.2.0) Commands are suggestions: review each one before running it.
Loading voting…