tschaub gh-pages vulnerable to prototype pollution
CVE-2022-37611GHSA-8mmm-9v2q-x3f9
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (gh-pages 5.0.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm gh-pages
- Affected
- < 5.0.0
- Fixed in
- 5.0.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-8mmm-9v2q-x3f9 lists affected ranges: npm gh-pages >=0 <5.0.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-8mmm-9v2q-x3f9 lists affected ranges: npm gh-pages >=0 <5.0.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2022-37611: 1.37% estimated exploitation activity in the next 30 days; percentile 72.02 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Prototype pollution vulnerability in tschaub gh-pages via the partial variable in util.js.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-8mmm-9v2q-x3f9
- Revision 1 · created ·
Published from osv record GHSA-8mmm-9v2q-x3f9
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-37611 Advisory: tschaub gh-pages vulnerable to prototype pollution IDs: CVE-2022-37611, GHSA-8mmm-9v2q-x3f9 Record: https://patchnext.com/advisories/cve-2022-37611 (revision 2, source checked 26 Oct 2026, 12:30 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: gh-pages 5.0.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm gh-pages: affected < 5.0.0; fixed in 5.0.0 ## Suggested inspection (read-only) - `npm ls gh-pages --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on gh-pages. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-8mmm-9v2q-x3f9 (OSV record GHSA-8mmm-9v2q-x3f9 lists affected ranges: npm gh-pages >=0 <5.0.0 (fixed)) - Verified: https://github.com/advisories/GHSA-8mmm-9v2q-x3f9 (GitHub-reviewed advisory GHSA-8mmm-9v2q-x3f9 lists affected ranges: npm gh-pages >=0 <5.0.0) Commands are suggestions: review each one before running it.
Loading voting…