Skip to content

← Actionable
Critical, CVSS 9.8amended

Buffer overflow in sponge queue functions

CVE-2022-37454GHSA-6w4m-2xhg-2658

What to do

Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI pysha3

    Affected
    <= 1.0.2
    Fixed in
    no fixed version recorded
  • RubyGems sha3

    Affected
    < 1.0.5
    Fixed in
    1.0.5

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2022-37454: 7.41% estimated exploitation activity in the next 30 days; percentile 94.45 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact The Keccak sponge function interface accepts partial inputs to be absorbed and partial outputs to be squeezed. A buffer can overflow when partial data with some specific sizes are queued, where at least one of them has a length of 2^32 - 200 bytes or more. Patches Yes, see commit fdc6fef0. Workarounds The problem can be avoided by limiting the size of the partial input data (or partial output digest) below 2^32 - 200 bytes. Multiple calls to the queue system can be chained at a higher level to retain the original functionality. Alternatively, one can process the entire input (or produce the entire output) at once, avoiding the queuing functions altogether. References See issue #105 for more details.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-6w4m-2xhg-2658

  2. Revision 1 · created ·

    Published from osv record GHSA-6w4m-2xhg-2658

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-37454

Advisory: Buffer overflow in sponge queue functions
IDs: CVE-2022-37454, GHSA-6w4m-2xhg-2658
Record: https://patchnext.com/advisories/cve-2022-37454 (revision 2, source checked 26 Oct 2026, 13:11 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Partial vendor fix; fixed versions by package: sha3 1.0.5. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI pysha3: affected <= 1.0.2
- RubyGems sha3: affected < 1.0.5; fixed in 1.0.5

## Suggested inspection (read-only)
- `python -m pip show pysha3`: prints the installed version. Run with the environment that serves production active.
- RubyGems sha3: check the installed version with your package manager.

## Supported action
No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on pysha3, sha3.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-6w4m-2xhg-2658 (OSV record GHSA-6w4m-2xhg-2658 lists affected ranges: PyPI pysha3 >=0 =0 <1.0.5 (fixed))
- Verified: https://github.com/advisories/GHSA-6w4m-2xhg-2658 (GitHub-reviewed advisory GHSA-6w4m-2xhg-2658 lists affected ranges: PyPI pysha3 >=0 =0 <1.0.5)

Commands are suggestions: review each one before running it.

Loading voting…