Skip to content

← Actionable
Unrated

Neo4j Graph apoc plugins Partial Path Traversal Vulnerability

CVE-2022-37423GHSA-78f9-745f-278p

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.neo4j.procedure:apoc 4.4.0.8, 4.3.0.7), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
not scored
EPSS
  • CVE-2022-37423: 1.48% estimated exploitation activity in the next 30 days; percentile 73.91 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact A partial Directory Traversal Vulnerability found in apoc.log.stream function of apoc plugins in Neo4j Graph database. This issue allows a malicious actor to potentially break out of the expected directory. The impact is limited to sibling directories. For example, userControlled.getCanonicalPath().startsWith("/usr/out") will allow an attacker to access a directory with a name like /usr/outnot. Patches The users should aim to use the latest released version compatible with their Neo4j version. The minimum versions containing patch for this vulnerability are 4.4.0.8 and 4.3.0.7 Workarounds If you cannot upgrade the library, you can control the allowlist of the functions that can be used in your system For more information If you have any questions or comments about this advisory: - Open an issue in neo4j-apoc-procedures - Email us at security@neo4j.com Credits We want to publicly recognise the contribution of Jonathan Leitschuh for reporting this issue.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-78f9-745f-278p

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-37423

Advisory: Neo4j Graph apoc plugins Partial Path Traversal Vulnerability
IDs: CVE-2022-37423, GHSA-78f9-745f-278p
Record: https://patchnext.com/advisories/cve-2022-37423 (revision 1, source checked 26 Oct 2026, 16:01 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Unrated
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.neo4j.procedure:apoc 4.4.0.8, 4.3.0.7. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.neo4j.procedure:apoc: affected >= 4.4.0.0, < 4.4.0.8; < 4.3.0.7; fixed in 4.3.0.7, 4.4.0.8

## Suggested inspection (read-only)
- Maven org.neo4j.procedure:apoc: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.neo4j.procedure:apoc.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-78f9-745f-278p (GitHub-reviewed advisory GHSA-78f9-745f-278p lists affected ranges: Maven org.neo4j.procedure:apoc >=4.4.0.0 =0 <4.3.0.7)

Commands are suggestions: review each one before running it.

Loading voting…