Skip to content

← Actionable
High, CVSS 7.5

Path Traversal in Payara

CVE-2022-37422GHSA-h28c-453m-h9xm

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (fish.payara.api:payara-bom 5.2022.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
EPSS
  • CVE-2022-37422: 1.18% estimated exploitation activity in the next 30 days; percentile 67.80 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Payara through 5.2022.2 allows directory traversal without authentication. This affects Payara Server, Payara Micro, and Payara Server Embedded.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-h28c-453m-h9xm

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-37422

Advisory: Path Traversal in Payara
IDs: CVE-2022-37422, GHSA-h28c-453m-h9xm
Record: https://patchnext.com/advisories/cve-2022-37422 (revision 1, source checked 26 Oct 2026, 16:01 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: fish.payara.api:payara-bom 5.2022.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven fish.payara.api:payara-bom: affected < 5.2022.3; fixed in 5.2022.3

## Suggested inspection (read-only)
- Maven fish.payara.api:payara-bom: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on fish.payara.api:payara-bom.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-h28c-453m-h9xm (GitHub-reviewed advisory GHSA-h28c-453m-h9xm lists affected ranges: Maven fish.payara.api:payara-bom >=0 <5.2022.3)

Commands are suggestions: review each one before running it.

Loading voting…