Craft CMS Cross-site Scripting vulnerability
CVE-2022-37246GHSA-f546-v666-559x
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (craftcms/cms 4.2.1, 3.7.51), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist craftcms/cms
- Affected
- >= 4.0.0-RC1, < 4.2.1>= 3.7.39, < 3.7.51
- Fixed in
- 4.2.1, 3.7.51
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-f546-v666-559x lists affected ranges: Packagist craftcms/cms >=4.0.0-RC1 =3.7.39 <3.7.51
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.4 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
- EPSS
- CVE-2022-37246: 0.52% estimated exploitation activity in the next 30 days; percentile 44.24 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Craft CMS 4.2.0.1 is affected by Cross Site Scripting (XSS) in the file src/web/assets/cp/src/js/BaseElementSelectInput.js and in specific on the line label: elementInfo.label.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-f546-v666-559x
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-37246 Advisory: Craft CMS Cross-site Scripting vulnerability IDs: CVE-2022-37246, GHSA-f546-v666-559x Record: https://patchnext.com/advisories/cve-2022-37246 (revision 1, source checked 26 Oct 2026, 14:00 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: craftcms/cms 4.2.1, 3.7.51. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist craftcms/cms: affected >= 4.0.0-RC1, < 4.2.1; >= 3.7.39, < 3.7.51; fixed in 4.2.1, 3.7.51 ## Suggested inspection (read-only) - Packagist craftcms/cms: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on craftcms/cms. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-f546-v666-559x (GitHub-reviewed advisory GHSA-f546-v666-559x lists affected ranges: Packagist craftcms/cms >=4.0.0-RC1 =3.7.39 <3.7.51) Commands are suggestions: review each one before running it.
Loading voting…