Jenkins Compuware Xpediter Code Coverage Plugin Missing Authorization
CVE-2022-36897GHSA-hxf7-9rv9-88v6
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (com.compuware.jenkins:compuware-xpediter-code-coverage 1.0.8), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven com.compuware.jenkins:compuware-xpediter-code-coverage
- Affected
- <= 1.0.7
- Fixed in
- 1.0.8
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-hxf7-9rv9-88v6 lists affected ranges: Maven com.compuware.jenkins:compuware-xpediter-code-coverage >=0 <=1.0.7
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 4.3 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
- EPSS
- CVE-2022-36897: 0.68% estimated exploitation activity in the next 30 days; percentile 52.48 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Jenkins Compuware Xpediter Code Coverage Plugin 1.0.7 and earlier does not perform permission checks in several HTTP endpoints. This allows attackers with Overall/Read permission to enumerate hosts and ports of Compuware configurations and credentials IDs of credentials stored in Jenkins. Those credentials IDs can be used as part of an attack to capture the credentials using another vulnerability. Compuware Xpediter Code Coverage Plugin 1.0.8 requires the appropriate permissions to enumerate hosts and ports of Compuware configurations and credentials IDs.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-hxf7-9rv9-88v6
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-36897 Advisory: Jenkins Compuware Xpediter Code Coverage Plugin Missing Authorization IDs: CVE-2022-36897, GHSA-hxf7-9rv9-88v6 Record: https://patchnext.com/advisories/cve-2022-36897 (revision 1, source checked 26 Oct 2026, 16:24 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 4.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: com.compuware.jenkins:compuware-xpediter-code-coverage 1.0.8. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven com.compuware.jenkins:compuware-xpediter-code-coverage: affected <= 1.0.7; fixed in 1.0.8 ## Suggested inspection (read-only) - Maven com.compuware.jenkins:compuware-xpediter-code-coverage: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on com.compuware.jenkins:compuware-xpediter-code-coverage. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-hxf7-9rv9-88v6 (GitHub-reviewed advisory GHSA-hxf7-9rv9-88v6 lists affected ranges: Maven com.compuware.jenkins:compuware-xpediter-code-coverage >=0 <=1.0.7) Commands are suggestions: review each one before running it.
Loading voting…