Gluu Oxauth before v4.4.1 vulnerable to Server-Side Request Forgery attacks via a crafted request_uri parameter
CVE-2022-36663GHSA-hc94-9v26-gxwv
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.gluu:oxauth-common 4.4.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.gluu:oxauth-common
- Affected
- < 4.4.1
- Fixed in
- 4.4.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-hc94-9v26-gxwv lists affected ranges: Maven org.gluu:oxauth-common >=0 <4.4.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2022-36663: 2.58% estimated exploitation activity in the next 30 days; percentile 85.24 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Gluu Oxauth before v4.4.1 allows attackers to execute blind SSRF (Server-Side Request Forgery) attacks via a crafted requesturi parameter.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-hc94-9v26-gxwv
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-36663 Advisory: Gluu Oxauth before v4.4.1 vulnerable to Server-Side Request Forgery attacks via a crafted request_uri parameter IDs: CVE-2022-36663, GHSA-hc94-9v26-gxwv Record: https://patchnext.com/advisories/cve-2022-36663 (revision 1, source checked 26 Oct 2026, 16:11 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.gluu:oxauth-common 4.4.1. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.gluu:oxauth-common: affected < 4.4.1; fixed in 4.4.1 ## Suggested inspection (read-only) - Maven org.gluu:oxauth-common: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.gluu:oxauth-common. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-hc94-9v26-gxwv (GitHub-reviewed advisory GHSA-hc94-9v26-gxwv lists affected ranges: Maven org.gluu:oxauth-common >=0 <4.4.1) Commands are suggestions: review each one before running it.
Loading voting…