VNCAuthProxy authentication bypass vulnerability
CVE-2022-36436GHSA-237r-mx84-7x8c
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (vncauthproxy 1.2.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI vncauthproxy
- Affected
- < 1.2.0
- Fixed in
- 1.2.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-237r-mx84-7x8c lists affected ranges: PyPI vncauthproxy >=0 <1.2.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-237r-mx84-7x8c lists affected ranges: PyPI vncauthproxy >=0 <1.2.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 9.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2022-36436: 2.07% estimated exploitation activity in the next 30 days; percentile 81.46 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
OSU Open Source Lab VNCAuthProxy through 1.1.1 is affected by an vncap/vnc/protocol.py VNCServerAuthenticator authentication-bypass vulnerability that could allow a malicious actor to gain unauthorized access to a VNC session or to disconnect a legitimate user from a VNC session. A remote attacker with network access to the proxy server could leverage this vulnerability to connect to VNC servers protected by the proxy server without providing any authentication credentials. Exploitation of this issue requires that the proxy server is currently accepting connections for the target VNC server.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-237r-mx84-7x8c
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-237r-mx84-7x8c
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-36436 Advisory: VNCAuthProxy authentication bypass vulnerability IDs: CVE-2022-36436, GHSA-237r-mx84-7x8c Record: https://patchnext.com/advisories/cve-2022-36436 (revision 3, source checked 26 Oct 2026, 13:16 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: vncauthproxy 1.2.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI vncauthproxy: affected < 1.2.0; fixed in 1.2.0 ## Suggested inspection (read-only) - `python -m pip show vncauthproxy`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on vncauthproxy. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-237r-mx84-7x8c (OSV record GHSA-237r-mx84-7x8c lists affected ranges: PyPI vncauthproxy >=0 <1.2.0 (fixed)) - Verified: https://github.com/advisories/GHSA-237r-mx84-7x8c (GitHub-reviewed advisory GHSA-237r-mx84-7x8c lists affected ranges: PyPI vncauthproxy >=0 <1.2.0) Commands are suggestions: review each one before running it.
Loading voting…