Skip to content

← Actionable
High, CVSS 7.5amended

file-type vulnerable to Infinite Loop via malformed MKV file

CVE-2022-36313GHSA-mhxj-85r3-2x55

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (file-type 17.1.3, 16.5.4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm file-type

    Affected
    >= 17.0.0, < 17.1.3>= 13.0.0, < 16.5.4
    Fixed in
    17.1.3, 16.5.4

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2022-36313: 0.41% estimated exploitation activity in the next 30 days; percentile 34.96 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

An issue was discovered in the file-type package from 13.0.0 until 16.5.4 and 17.x before 17.1.3 for Node.js. A malformed MKV file could cause the file type detector to get caught in an infinite loop. This would make the application become unresponsive and could be used to cause a DoS attack when used on a web server.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-mhxj-85r3-2x55

  2. Revision 1 · created ·

    Published from osv record GHSA-mhxj-85r3-2x55

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-36313

Advisory: file-type vulnerable to Infinite Loop via malformed MKV file
IDs: CVE-2022-36313, GHSA-mhxj-85r3-2x55
Record: https://patchnext.com/advisories/cve-2022-36313 (revision 2, source checked 26 Oct 2026, 12:16 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: file-type 17.1.3, 16.5.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm file-type: affected >= 17.0.0, < 17.1.3; >= 13.0.0, < 16.5.4; fixed in 17.1.3, 16.5.4

## Suggested inspection (read-only)
- `npm ls file-type --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on file-type.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-mhxj-85r3-2x55 (OSV record GHSA-mhxj-85r3-2x55 lists affected ranges: npm file-type >=13.0.0 =17.0.0 <17.1.3 (fixed))
- Verified: https://github.com/advisories/GHSA-mhxj-85r3-2x55 (GitHub-reviewed advisory GHSA-mhxj-85r3-2x55 lists affected ranges: npm file-type >=17.0.0 =13.0.0 <16.5.4)

Commands are suggestions: review each one before running it.

Loading voting…