Apache SkyWalking NodeJS Agent can lose availability if header includes illegal SkyWalking header
CVE-2022-36127GHSA-8gpg-466c-5cpj
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (skywalking-backend-js 0.5.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- < 0.5.1
- Fixed in
- 0.5.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-8gpg-466c-5cpj lists affected ranges: npm skywalking-backend-js >=0 <0.5.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-8gpg-466c-5cpj lists affected ranges: npm skywalking-backend-js >=0 <0.5.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2022-36127: 1.87% estimated exploitation activity in the next 30 days; percentile 79.33 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
A vulnerability in Apache SkyWalking NodeJS Agent prior to 0.5.1. The vulnerability will cause NodeJS services that has this agent installed to be unavailable if the OAP is unhealthy and NodeJS agent can't establish the connection.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-8gpg-466c-5cpj
- Revision 1 · created ·
Published from osv record GHSA-8gpg-466c-5cpj
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-36127 Advisory: Apache SkyWalking NodeJS Agent can lose availability if header includes illegal SkyWalking header IDs: CVE-2022-36127, GHSA-8gpg-466c-5cpj Record: https://patchnext.com/advisories/cve-2022-36127 (revision 2, source checked 26 Oct 2026, 12:16 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: skywalking-backend-js 0.5.1. A vendor fix does not mean a deployment is fixed. ## Affected components - npm skywalking-backend-js: affected < 0.5.1; fixed in 0.5.1 ## Suggested inspection (read-only) - `npm ls skywalking-backend-js --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on skywalking-backend-js. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-8gpg-466c-5cpj (OSV record GHSA-8gpg-466c-5cpj lists affected ranges: npm skywalking-backend-js >=0 <0.5.1 (fixed)) - Verified: https://github.com/advisories/GHSA-8gpg-466c-5cpj (GitHub-reviewed advisory GHSA-8gpg-466c-5cpj lists affected ranges: npm skywalking-backend-js >=0 <0.5.1) Commands are suggestions: review each one before running it.
Loading voting…